Bug 595414 - abrtd: Can't create database '/var/cache/abrt/abrt-db': unable to open database file
Summary: abrtd: Can't create database '/var/cache/abrt/abrt-db': unable to open databa...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Jiri Moskovcak
QA Contact: Michal Nowak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 14:48 UTC by Michal Nowak
Modified: 2015-02-01 22:52 UTC (History)
7 users (show)

Fixed In Version: abrt-1.1.3-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-02 18:47:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Michal Nowak 2010-05-24 14:48:24 UTC
Description of problem:

newman@dhcp-lab-222 ~ $ sudo service abrtd restart
Stopping abrt daemon: May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Reporter plugin Bugzilla
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Analyzer plugin CCpp
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Action plugin FileTransfer
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Analyzer plugin Kerneloops
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Action plugin KerneloopsScanner
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Analyzer plugin Kerneloops
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Action plugin KerneloopsScanner
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Reporter plugin Logger
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Reporter plugin Mailx
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Reporter plugin Mailx
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Analyzer plugin Python
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Action plugin SOSreport
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Action plugin SOSreport
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Database plugin SQLite3
May 24 16:42:36 dhcp-lab-222 abrtd: UnRegistered Reporter plugin TicketUploader
May 24 16:42:36 dhcp-lab-222 abrtd: Got signal 15, exiting
May 24 16:42:36 dhcp-lab-222 abrtd: Got signal 15, exiting
                                                           [  OK  ]
Starting abrt daemon: May 24 16:42:36 dhcp-lab-222 abrtd: Registered Reporter plugin 'Logger'
May 24 16:42:36 dhcp-lab-222 abrtd: Registered Reporter plugin 'Bugzilla'
May 24 16:42:36 dhcp-lab-222 abrtd: Registered Analyzer plugin 'CCpp'
May 24 16:42:36 dhcp-lab-222 abrtd: Registered Action plugin 'SOSreport'
May 24 16:42:36 dhcp-lab-222 abrtd: Registered Reporter plugin 'Mailx'
May 24 16:42:36 dhcp-lab-222 abrtd: Registered Analyzer plugin 'Kerneloops'
May 24 16:42:36 dhcp-lab-222 abrtd: Registered Action plugin 'KerneloopsScanner'
May 24 16:42:36 dhcp-lab-222 abrtd: Registered Analyzer plugin 'Python'
May 24 16:42:36 dhcp-lab-222 abrtd: Registered Reporter plugin 'TicketUploader'
May 24 16:42:36 dhcp-lab-222 abrtd: Registered Action plugin 'FileTransfer'
May 24 16:42:36 dhcp-lab-222 abrtd: Checking for unsaved crashes (dirs to check:2)
May 24 16:42:36 dhcp-lab-222 abrtd: Registered Database plugin 'SQLite3'
May 24 16:42:36 dhcp-lab-222 abrtd: Can't create database '/var/cache/abrt/abrt-db': unable to open database file
May 24 16:42:36 dhcp-lab-222 abrtd: Can't create database '/var/cache/abrt/abrt-db': unable to open database file
May 24 16:42:36 dhcp-lab-222 abrtd: Done checking for unsaved crashes
May 24 16:42:36 dhcp-lab-222 abrtd: Init complete, entering main loop


Version-Release number of selected component (if applicable):

abrt-1.1.2-3.el6.x86_64

How reproducible:

always

Steps to Reproduce:
1. start abrtd
  
Actual results:

Fails due to problem with moved abrt main directory from /var/cache/ to /var/spool/

Expected results:


Additional info:

newman@dhcp-lab-222 abrt $ sudo grep var -R /etc/abrt/plugins/SQLite3.conf 
DBPath = /var/cache/abrt/abrt-db

Comment 1 Denys Vlasenko 2010-05-24 15:21:37 UTC
Why it can't create /var/cache/abrt/abrt-db? There is no /var/cache/abrt? selinux denial? other?

Comment 2 Michal Nowak 2010-05-25 11:05:54 UTC
Yes. /var/cache/abrt was missing at the time, now with 1.1.3 it was recreated.

Comment 6 releng-rhel@redhat.com 2010-07-02 18:47:51 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.