Bug 595433 - support backwards compatibility for queries
support backwards compatibility for queries
Status: CLOSED WONTFIX
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
All Linux
low Severity high
: ---
: ---
Assigned To: Barak
infra
: CodeChange
Depends On:
Blocks: 607657
  Show dependency treegraph
 
Reported: 2010-05-24 11:36 EDT by lpeer
Modified: 2012-12-23 04:20 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-23 04:20:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lpeer 2010-05-24 11:36:22 EDT
Description of problem:

The infra structure for supporting backwards compatibilities for queries is missing.
Note: The ids of queries and commands collide, we need to add a prefix for the id or use two tables.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Miki Kenneth 2010-06-07 10:03:33 EDT
livnat ????
Comment 2 lpeer 2010-06-08 10:24:45 EDT
please see bug -
Bug 595123
	
We do not have a mechanism to avoid running specific queries on 2.1 hosts.
Comment 3 Itamar Heim 2012-12-23 04:20:24 EST
Closing old bugs. If this issue is still relevant/important in current version, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.