Bug 59544 - Bad fonts.scale file + another startup problem
Bad fonts.scale file + another startup problem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: abiword (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-09 21:02 EST by David L. Parsley
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-19 14:25:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David L. Parsley 2002-02-09 21:02:48 EST
Description of Problem:
This is really two bugs in one report. ;-)  The fonts.scale file in the abiword
fonts directory has blank lines at the end, which buggers mkfontdir.  Once I
removed the blank lines it fixed the font problem, but even then abiword
segfaults on startup. :-(
Comment 1 Bernhard Rosenkraenzer 2002-02-27 06:07:40 EST
This is because for some reason, xset +fp fails to work even if fonts.scale is fixed: 
 
[root@spock fonts]# xset +fp /usr/share/AbiSuite/fonts 
X Error of failed request:  86 
  Major opcode of failed request:  51 (X_SetFontPath) 
  Serial number of failed request:  8 
  Current serial number in output stream:  10 
 
Might be an X bug after all.
Comment 2 David L. Parsley 2002-02-27 14:01:28 EST
I d/l'ed the latest Abiword from abisource, and the included fonts.scale had the
same problem.  Once I removed the blank lines, though, I did mkfontdir &
chkfontpath (add abisource fonts) and it started fine.  Still crashed whenever I
closed a window tho.  I'll check this out again on the next beta.
Comment 3 Mike A. Harris 2002-02-27 19:14:24 EST
If the file contains blank lines, then it is a bad file.  ttmkfdir should
be used to create fonts.scale.

xset +fp will never work in a default Red Hat Linux setup because we use
the xfs fotn server, and xset +fp talks to the X server - which is not
serving any fonts.

The proper way for this to be handled IMHO is for the Abiword package to
install its fonts, and run chkfontpath in it's post install script like all of
our other font packages do, which also then allows the fonts to be used by
other applications.
Comment 4 Jay Turner 2002-03-19 14:25:15 EST
So, what's the resolution to this?

Note You need to log in before you can comment on or make changes to this bug.