Bug 595442 - zfs-fuse 0.6.9_beta3-6.fc14 not built with $RPM_OPT_FLAGS
Summary: zfs-fuse 0.6.9_beta3-6.fc14 not built with $RPM_OPT_FLAGS
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: zfs-fuse   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Uwe Kubosch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks: DebugInfo
TreeView+ depends on / blocked
 
Reported: 2010-05-24 16:00 UTC by Ville Skyttä
Modified: 2010-07-13 07:27 UTC (History)
1 user (show)

Fixed In Version: zfs-fuse-0.6.9-5.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 07:24:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2010-05-24 16:00:01 UTC
http://kojipkgs.fedoraproject.org/packages/zfs-fuse/0.6.9_beta3/6.fc14/data/logs/x86_64/build.log

zfs-fuse 0.6.9_beta3-6.fc14.x86_64 is not built with $RPM_OPT_FLAGS (and seems to add -s to CFLAGS), causing an empty -debuginfo package and other potential problems.  Previous package release did not appear to have this issue.  See blocker bug for more information.

Comment 1 Uwe Kubosch 2010-05-25 00:51:32 UTC
Is this better?

http://koji.fedoraproject.org/koji/taskinfo?taskID=2207295

I fixed a sed replace that stopped matching after an upstream change, and added a debug=0 flag to the build.

Comment 2 Ville Skyttä 2010-05-25 05:18:01 UTC
Seems to have improved slightly ($RPM_OPT_FLAGS is now used in some gcc invocations), but there are still quite a few ones where it is not.  And even in the ones that do have those flags, there's still the -s which will make -debuginfo useless.

http://koji.fedoraproject.org/koji/getfile?taskID=2207299&name=build.log

Look at the gcc lines, you should find (on x86_64) these options given to it for each compilation unit: "-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic" ...and you should not find -s there.

Also, after your build is done, list files included in the -debuginfo package; if it's empty or missing some *.debug files for executables/libraries, or missing sources where they were compiled from, something's certainly wrong.

Comment 3 Uwe Kubosch 2010-07-04 00:53:33 UTC
So, I found a debug flag in the scons scripts and turned it on.  This removed the -s flag.

I have made new tags and builds.  The debuginfo packages are nice and fat.  Could you look at the builds and see if they look OK?

http://koji.fedoraproject.org/koji/buildinfo?buildID=181427
http://koji.fedoraproject.org/koji/buildinfo?buildID=181428
http://koji.fedoraproject.org/koji/buildinfo?buildID=181429
http://koji.fedoraproject.org/koji/buildinfo?buildID=181430
http://koji.fedoraproject.org/koji/buildinfo?buildID=181431

Comment 4 Fedora Update System 2010-07-04 01:06:31 UTC
zfs-fuse-0.6.9-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/zfs-fuse-0.6.9-2.fc13

Comment 5 Fedora Update System 2010-07-04 01:09:27 UTC
zfs-fuse-0.6.9-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/zfs-fuse-0.6.9-2.fc12

Comment 6 Ville Skyttä 2010-07-04 07:44:21 UTC
-debuginfos look ok now on a brief look.  Unless you've already done it, I suggest going through the sources and verifying what the DEBUG define enables because -DDEBUG is now passed to the build.  (E.g. check if it enables some features or extra output or the like that would not be desirable in end user builds.)

Comment 7 Uwe Kubosch 2010-07-04 10:58:16 UTC
Yes, the DEBUG flag was wrong.  I have now changed to pass the NDEBUG flag to the scripts, which removes the debug code while still generating debug symbols.

http://koji.fedoraproject.org/koji/buildinfo?buildID=181460

Thanks for looking into this :)

Comment 8 Fedora Update System 2010-07-04 13:58:10 UTC
zfs-fuse-0.6.9-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/zfs-fuse-0.6.9-4.fc12

Comment 9 Fedora Update System 2010-07-04 14:36:41 UTC
zfs-fuse-0.6.9-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/zfs-fuse-0.6.9-4.fc13

Comment 10 Fedora Update System 2010-07-04 21:49:39 UTC
zfs-fuse-0.6.9-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/zfs-fuse-0.6.9-5.fc13

Comment 11 Fedora Update System 2010-07-04 21:51:30 UTC
zfs-fuse-0.6.9-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/zfs-fuse-0.6.9-5.fc12

Comment 12 Fedora Update System 2010-07-06 17:20:32 UTC
zfs-fuse-0.6.9-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update zfs-fuse'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/zfs-fuse-0.6.9-5.fc12

Comment 13 Fedora Update System 2010-07-06 17:22:22 UTC
zfs-fuse-0.6.9-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update zfs-fuse'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/zfs-fuse-0.6.9-5.fc13

Comment 14 Fedora Update System 2010-07-13 07:23:51 UTC
zfs-fuse-0.6.9-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-07-13 07:26:48 UTC
zfs-fuse-0.6.9-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.