Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 595457 - gnome-keyring-sharp uses deprecated socket interface; apps cannot use keyring
gnome-keyring-sharp uses deprecated socket interface; apps cannot use keyring
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-keyring-sharp (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 12:40 EDT by Christian Krause
Modified: 2010-06-30 11:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: gnome-keyring-sharp-1.0.1-0.6.133722svn.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 11:18:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 608459 None None None Never
Novell 589166 None None None Never
Launchpad 536925 None None None Never

  None (edit)
Description Christian Krause 2010-05-24 12:40:26 EDT
Description of problem:
- gnome-keyring-sharp uses deprecated socket interface

How reproducible:
100%

Steps to Reproduce:
1. e.g. install gnome-rdp and start it in a terminal
2. add a new session
3. choose rdp and enter any values (dummy values are just fine)
  
Actual results:
- user name / password not saved
- error message on console
Gnome.Keyring.KeyringException: The keyring daemon is not available
  at Gnome.Keyring.Ring.SendRequest (System.IO.MemoryStream stream) [0x00000] in <filename unknown>:0
  at Gnome.Keyring.Ring.GetDefaultKeyring () [0x00000] in <filename unknown>:0
  at GnomeRDP.KeyringProxy.GetPassword (System.String user, System.String domain, System.String server, Int32 protocol) [0x00000] in <filename unknown>:0


Expected results:
- user name / password should be saved
Comment 1 Fedora Update System 2010-06-13 16:15:30 EDT
gnome-keyring-sharp-1.0.1-0.6.133722svn.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gnome-keyring-sharp-1.0.1-0.6.133722svn.fc13
Comment 2 Fedora Update System 2010-06-14 13:16:04 EDT
gnome-keyring-sharp-1.0.1-0.6.133722svn.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-keyring-sharp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gnome-keyring-sharp-1.0.1-0.6.133722svn.fc13
Comment 3 Charles Butterfield 2010-06-22 00:09:58 EDT
Prior update (gnome-keyring-sharp-1.0.1-0.6.133722svn.fc13) DOES NOT WORK FOR ME.

Password are still not remembered.  Running from the command line, I see "Duplicate entries found. Deleting item 7 from keyring login". Each time I try to save a password, the index (e.g. 7) gets incremented by one.  There is nothing interesting to be seem from seahorse (well other than 2 prior VPN secrets).

I entered this on the incredibly annoying link mentioned above. The area for comments is incredibly tiny and the captcha is insanely hard to decipher.  It took me 7 attempts, and of course my email got wiped.  I am the "anonymous poster" listed there.
Comment 4 Christian Krause 2010-06-27 12:38:41 EDT
(In reply to comment #3)
> Prior update (gnome-keyring-sharp-1.0.1-0.6.133722svn.fc13) DOES NOT WORK FOR
> ME.
> 
> Password are still not remembered.  Running from the command line, I see
> "Duplicate entries found. Deleting item 7 from keyring login". Each time I try
> to save a password, the index (e.g. 7) gets incremented by one.  There is
> nothing interesting to be seem from seahorse (well other than 2 prior VPN
> secrets).

I have investigated the issue:
- gnome-rdp retrieves the default keyring (which is returned as NULL)
- gnome-rdp saves the passwords to the default keyring
- gnome-rdp looks up the password and compares the associated keyring (which is for whatever reason "login" (which seems to be some kind of default keyring today)); if the associated keyring of the entry does not match the default keyring, gnome-rdp deletes this entry

I have verified that even a plain usage of libgnome-keyring retrieves the default keyring as "NULL", so the problem is either in gnome-keyring (which does not report a meaningful default keyring) or in the logic how gnome-rdp handles the default keyring.

Additionally I have successfully verified the functionality of gnome-keyring-sharp with f-spot and its Picasa support.

Since the problem is not in this package, let's track the described issue with gnome-rdp and gnome-keyring in a different bug report: https://bugzilla.redhat.com/show_bug.cgi?id=608459

> I entered this on the incredibly annoying link mentioned above. The area for
> comments is incredibly tiny and the captcha is insanely hard to decipher.  It
> took me 7 attempts, and of course my email got wiped.  I am the "anonymous
> poster" listed there.    

This bug report is not the correct place to handle these kind of issues. Please report them via https://fedorahosted.org/bodhi/newticket .
Comment 5 Fedora Update System 2010-06-30 11:18:28 EDT
gnome-keyring-sharp-1.0.1-0.6.133722svn.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.