Bug 595473 - SSM Child Channels subscription not updating current members in 530
SSM Child Channels subscription not updating current members in 530
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Petr Sklenar
:
: 569758 (view as bug list)
Depends On:
Blocks: sat531-triage
  Show dependency treegraph
 
Reported: 2010-05-24 14:14 EDT by Partha Aji
Modified: 2010-11-18 03:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-18 03:29:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0897 normal SHIPPED_LIVE Red Hat Network Satellite bug fix update 2010-11-18 03:27:31 EST

  None (edit)
Description Partha Aji 2010-05-24 14:14:01 EDT
Description of problem:
If one subscribes or unsubscribes a child channels to/from a server in SSM, the entitlement counts and the package errata server cache will not get updated causing all those calculations to fail.

Version-Release number of selected component (if applicable): 530


How reproducible: Always


Steps to Reproduce:
1. Go to Subscription Management -> Software Channel Entitlements
2. Look and make a note for the Red Hat Network Tools for Red Hat Enterprise Linux -> Entitled and Available counts
3. Add systems that don;t have the RHN tools channel but are subscribed to a RH base channel to ssm.
4. Goto Manage -> Channels -> Child Channels
5. Select subscribe on "Red Hat Network Tools" + hit alter subscriptions and confirm appropriately
6. Go to Subscription Management -> Software Channel Entitlements
7. Look at the  Entitled and Available counts for Red Hat Network Tools channel. 

Actual results:
Notice those numbers have not been updated at all.

Expected results:
Number of entitled must be more and number on available must be lesser.

Additional info:
Comment 1 Justin Sherrill 2010-05-25 17:47:37 EDT
fixed in spacewalk master:  
e1aa5c1ccc9baae1f85938bbc6801e7ac3adf4fc
397baaff9968ec1e747cc04d5193d7c0f91521c3
Comment 2 Justin Sherrill 2010-05-26 15:16:47 EDT
One last fix:
09b0052b46bf78853cdf7fd8900b43a76a588fcb
Comment 4 Partha Aji 2010-08-05 18:53:38 EDT
*** Bug 569758 has been marked as a duplicate of this bug. ***
Comment 5 Petr Sklenar 2010-08-11 04:14:38 EDT
reproduced up to Comment 0 or bug 569758#c0 with OLD version

new,spacewalk-java-0.5.44-86.el5sat works well, entitlement counter reflects changes in SSM  immediately
Comment 7 errata-xmlrpc 2010-11-18 03:29:43 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0897.html

Note You need to log in before you can comment on or make changes to this bug.