Bug 59548 - dhcpd binds to all interfaces, despite instructions to the contrary
Summary: dhcpd binds to all interfaces, despite instructions to the contrary
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-10 05:06 UTC by Jason Costomiris
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-10 05:06:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Costomiris 2002-02-10 05:06:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
In a machine with multiple interfaces and dhcpd running, even if you tell 
dhcpd to only bind to one specific interface, it binds to all.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a system with multiple network interfaces
2. Configure dhcpd with a subnet{ } config for one interface, don't configure 
the other.
3. Start up the dhcpd
	

Actual Results:  The dhcpd starts, and says that it only binds to one 
interface, however, netstat -an reveals the system has something bound to 
udp/67 on 0.0.0.0.

Expected Results:  I would expect it to behave the way BIND does when you use 
a listen-on{} directive in the options{} section.

Additional info:

Comment 1 Elliot Lee 2002-03-08 16:11:24 UTC
In /etc/sysconfig/dhcpd, you can do e.g.:

DHCPDARGS="eth1 eth3 eth5"

to have dhcpd bind only on eth1/eth3/eth5

Comment 2 Need Real Name 2002-05-10 19:21:48 UTC
No, this does not work, because /etc/rc.d/init.d/dhcpd looks like:

        daemon /usr/sbin/dhcpd ${DHCPDARGS}

it should be changed to:

        daemon /usr/sbin/dhcpd "${DHCPDARGS}"

Comment 3 Elliot Lee 2002-05-10 19:37:22 UTC
If the quotes are added, that will cause the entire contents of DHCPDARGS to be
treated as a single argument, which will definitely break things. dhcpd wants an
argument for each interface name to pay attention to.


Note You need to log in before you can comment on or make changes to this bug.