Bug 595481 - [abrt] kdeutils-printer-applet-6:4.4.3-1.fc14: <string>:23:getFilter:ImportError: /usr/lib/python2.6/site-packages/PyKDE4/kio.so: undefined symbol: _ZN13KUrlNavigator15keyReleaseEventEP9QKeyEvent
[abrt] kdeutils-printer-applet-6:4.4.3-1.fc14: <string>:23:getFilter:ImportEr...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
14
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:687b664f
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 14:54 EDT by STEVEN WARD
Modified: 2011-05-03 13:16 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-03 13:16:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (1.23 KB, text/plain)
2010-05-24 14:54 EDT, STEVEN WARD
no flags Details

  None (edit)
Description STEVEN WARD 2010-05-24 14:54:46 EDT
abrt version: 1.1.3
architecture: i686
cmdline: python /usr/bin/printer-applet
component: kdeutils
executable: /usr/bin/printer-applet
kernel: 2.6.34-11.fc14.i686.PAE
package: kdeutils-printer-applet-6:4.4.3-1.fc14
reason: <string>:23:getFilter:ImportError: /usr/lib/python2.6/site-packages/PyKDE4/kio.so: undefined symbol: _ZN13KUrlNavigator15keyReleaseEventEP9QKeyEvent
release: Fedora release 14 (Rawhide)

backtrace
-----
<string>:23:getFilter:ImportError: /usr/lib/python2.6/site-packages/PyKDE4/kio.so: undefined symbol: _ZN13KUrlNavigator15keyReleaseEventEP9QKeyEvent

Traceback (most recent call last):
  File "/usr/bin/printer-applet", line 1171, in <module>
    applet = JobManager()
  File "/usr/bin/printer-applet", line 241, in __init__
    uic.loadUi(APPDIR + "/" + "printer-applet.ui", self.mainWindow)
  File "/usr/lib/python2.6/site-packages/PyQt4/uic/__init__.py", line 177, in loadUi
    return DynamicUILoader().loadUi(uifile, baseinstance)
  File "/usr/lib/python2.6/site-packages/PyQt4/uic/Loader/loader.py", line 8, in __init__
    UIParser.__init__(self, QtCore, QtGui, LoaderCreatorPolicy())
  File "/usr/lib/python2.6/site-packages/PyQt4/uic/uiparser.py", line 87, in __init__
    self.factory = QObjectCreator(creatorPolicy)
  File "/usr/lib/python2.6/site-packages/PyQt4/uic/objcreator.py", line 57, in __init__
    self._cwFilters.append(plugin_locals["getFilter"]())
  File "<string>", line 23, in getFilter
ImportError: /usr/lib/python2.6/site-packages/PyKDE4/kio.so: undefined symbol: _ZN13KUrlNavigator15keyReleaseEventEP9QKeyEvent

Local variables in innermost frame:
PyKDE4: <module 'PyKDE4' from '/usr/lib/python2.6/site-packages/PyKDE4/__init__.pyc'>
Comment 1 STEVEN WARD 2010-05-24 14:54:48 EDT
Created attachment 416196 [details]
File: backtrace
Comment 2 Rex Dieter 2010-05-24 21:08:47 EDT
Most likely due to our current partial import of kde-4.5 beta1 into rawhide.

Once kdebindings-4.4.80 lands, please retest.

(that one is currently giving us fits, and fails to build unfortunately).
Comment 3 Kevin Kofler 2010-05-25 10:02:03 EDT
kdebindings is known for abusing private API (because the bindings are automatically generated and the generator doesn't know that some APIs are private).
Comment 4 Karsten Roch 2010-05-26 14:06:48 EDT
Package: kdeutils-printer-applet-6:4.4.80-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Rawhide)


How to reproduce
-----
1.Start kde, login
2. no printer connected
3. abrt pop up and report crash
Comment 5 Bug Zapper 2010-07-30 07:42:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bill McGonigle 2011-02-25 01:51:22 EST
kdeutils-printer-applet-4.6.0-0.1.fc14.x86_64


$ printer-applet 
Traceback (most recent call last):
  File "/usr/bin/printer-applet", line 1163, in <module>
    applet = JobManager()
  File "/usr/bin/printer-applet", line 241, in __init__
    uic.loadUi(unicode(APPDIR + '/' + "printer-applet.ui"), self.mainWindow)
  File "/usr/lib64/python2.7/site-packages/PyQt4/uic/__init__.py", line 221, in loadUi
    return DynamicUILoader().loadUi(uifile, baseinstance)
  File "/usr/lib64/python2.7/site-packages/PyQt4/uic/Loader/loader.py", line 50, in __init__
    UIParser.__init__(self, QtCore, QtGui, LoaderCreatorPolicy())
  File "/usr/lib64/python2.7/site-packages/PyQt4/uic/uiparser.py", line 127, in __init__
    self.factory = QObjectCreator(creatorPolicy)
  File "/usr/lib64/python2.7/site-packages/PyQt4/uic/objcreator.py", line 97, in __init__
    self._cwFilters.append(plugin_locals["getFilter"]())
  File "<string>", line 23, in getFilter
ImportError: /usr/lib64/python2.7/site-packages/PyKDE4/kio.so: undefined symbol: _ZN11KFileDialog16getOpenFileNamesERK4KUrlRK7QStringP7QWidgetS5_
Comment 7 Rex Dieter 2011-05-03 13:16:54 EDT
This should be fixed in official builds.

If not, holler.

Note You need to log in before you can comment on or make changes to this bug.