Bug 595487 - Anaconda silently failes because of not enough ram when launched from livecd
Anaconda silently failes because of not enough ram when launched from livecd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 15:11 EDT by Clemens Eisserer
Modified: 2014-09-30 19:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-25 09:36:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clemens Eisserer 2010-05-24 15:11:23 EDT
Description of problem:

I tried installing a Fedora-13RC3 LiveCD on a rather old computer (384mb ram, 17gb harddrive). 
Although the live-cd worked great, clicking on the "Install" icon simply did nothing - no error dialog, no popup, nothing.

When I searched in anaconda's log-file it mentioned there was not enough free RAM, so it launched in text-mode. Quite bad with X already running and without a console to see its output ;)


Version-Release number of selected component (if applicable):
Fedora13RC3 live cd

How reproducible:
Always


Steps to Reproduce:
1. Start live-cd on a system with 384mb ram or less
2. Click the "install"-icon on the desktop
  
Actual results:
Nothing happens, not even a notification popup.


Expected results:
Anaconda should check wether there's swap-space available, and report that the machine has less RAM than recommended and that therefor the installation, giving the user the choice between no installation and a (maybe?) slow one.

Additional info:
Comment 1 Ales Kozumplik 2010-05-25 01:32:17 EDT
Hi Clemens,

can you please attach /tmp/anaconda.log to this bug report?

Thanks.
Ales
Comment 2 Ales Kozumplik 2010-05-25 09:36:29 EDT
Forget it. This has been fixed rawhide, we didn't put it into f13 since it is not a blocker, see http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=3d977a502d773a1b1764b73f8e423c5350e1f929.

Note You need to log in before you can comment on or make changes to this bug.