Bug 595497 - [abrt] crash in codeblocks-8.02-9.fc12: _int_malloc: Process /usr/bin/codeblocks was killed by signal 11 (SIGSEGV)
[abrt] crash in codeblocks-8.02-9.fc12: _int_malloc: Process /usr/bin/codeblo...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: codeblocks (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
abrt_hash:97ca6dc92861b5a0e3b6020495a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 15:57 EDT by An00biS
Modified: 2010-05-27 04:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-27 04:59:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (181.74 KB, text/plain)
2010-05-24 15:57 EDT, An00biS
no flags Details

  None (edit)
Description An00biS 2010-05-24 15:57:48 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/codeblocks
comment: Code::Blocks crashed for me 12 times in total during random actions, like switching files, moving scrollbar, selecting or pasting, clicking to move caret, pressing F9 to 'compile and run' and such. No special circumstances were involved.
component: codeblocks
crash_function: _int_malloc
executable: /usr/bin/codeblocks
global_uuid: 97ca6dc92861b5a0e3b6020495aa882f86d52893
kernel: 2.6.32.11-99.fc12.i686
package: codeblocks-8.02-9.fc12
rating: 4
reason: Process /usr/bin/codeblocks was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Use Code::Blocks
2. ??
3. Profit.
Comment 1 An00biS 2010-05-24 15:57:54 EDT
Created attachment 416213 [details]
File: backtrace
Comment 2 Dan Horák 2010-05-25 02:24:23 EDT
C::B really should crash that often and during normal work and I haven't seen such behaviour yet. Please can you check whether your OS installation is not damaged and your hardware is OK (run a memory test etc.)? Do you have any large project opened?

Can you try to reproduce the problem in the latest nightly build available from
http://fedora.danny.cz/danny/ ? It's very close to the upcoming released version.
Comment 3 An00biS 2010-05-26 14:26:39 EDT
(In reply to comment #2)
> C::B really should crash that often and during normal work and I haven't seen
> such behaviour yet. Please can you check whether your OS installation is not
> damaged and your hardware is OK (run a memory test etc.)? Do you have any large
> project opened?
> 
> Can you try to reproduce the problem in the latest nightly build available from
> http://fedora.danny.cz/danny/ ? It's very close to the upcoming released
> version.    

Thanks for the RPM, but I already compiled the svn version (rev 6280). I tried all the actions which seemed to relate to the problems. No crash so far.

I don't think it could be caused by OS or harware because I'm not experiencing anything suspicious. And the new installation works without problems.

The project I worked on is quite small, some 15 files with roughly 50 - 200 lines each.
Comment 4 Dan Horák 2010-05-27 04:59:58 EDT
Thanks for the update, I will close the issue now as fixed in upstream code.

Note You need to log in before you can comment on or make changes to this bug.