Bug 595519 - gnome-media-apps using invalid ScrollKeeper category
Summary: gnome-media-apps using invalid ScrollKeeper category
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-media (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Bastien Nocera
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 21:03 UTC by Matthew Barnes
Modified: 2010-11-10 20:30 UTC (History)
2 users (show)

Fixed In Version: gnome-media-2.29.91-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 20:30:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix ScrollKeeper categories (2.87 KB, patch)
2010-05-24 21:51 UTC, Matthew Barnes
no flags Details | Diff

Description Matthew Barnes 2010-05-24 21:03:42 UTC
Filing this as a followup to bug #580081.  The bug is probably present in Fedora as well.

None of the applications in gnome-media-apps are listed in Yelp under the "Sound & Video" category because their OMF files are using an invalid ScrollKeeper category which rarian does not recognize.

In each OMF file, the following change is needed for it to appear in Yelp:

    - <subject category="GNOME|Applications|Sound and Video"/>
    + <subject category="GNOME|Multimedia"/>

Comment 1 RHEL Product and Program Management 2010-05-24 21:06:42 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Matthew Barnes 2010-05-24 21:51:52 UTC
Created attachment 416233 [details]
Fix ScrollKeeper categories

With this patch, and after a session restart, the applications will appear in Yelp under "Sound & Video".  (There's probably a shortcut that I'm not aware of to avoid a session restart.)

Comment 3 Tomas Pelka 2010-05-31 14:54:35 UTC
Verified on gnome-media-2.29.91-4.el6.

How to verified:
for i in $(rpm -ql gnome-media-apps | grep omf$); do echo "********$i*********"; grep 'category=\"GNOME' $i; done

Comment 4 releng-rhel@redhat.com 2010-11-10 20:30:46 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.