Bug 595532 - [Kernel] Kernel panic - not syncing: ERROR: Failed to allocate 0x4000 bytes below 0x10000000
[Kernel] Kernel panic - not syncing: ERROR: Failed to allocate 0x4000 bytes b...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Steve Best
Red Hat Kernel QE team
http://rhts.redhat.com/testlogs/2010/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 17:54 EDT by Jeff Burke
Modified: 2010-07-15 09:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 09:16:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2010-05-24 17:54:41 EDT
Description of problem:
 While testing the 2.6.32-29.el6.ppc64.debug kernel the systems panic'd

Version-Release number of selected component (if applicable):
 2.6.32-29.el6.ppc64.debug

How reproducible:
 intermittent 

Steps to Reproduce:
1. Install RHEL6.0-Snapshot4 Server, ppc64
2. Install the  2.6.32-29.el6.ppc64.debug kernel
3. Reboot until you see the issue.
  
Actual results:
Elapsed time since release of system processors: 132522 mins 43 secs

Config file read, 1024 bytes
Welcome to Red Hat Enterprise Linux!
Hit <TAB> for boot options
Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-30.el6)
Enter "help" to get some basic usage information
boot: linux
Please wait, loading kernel...
   Elf64 kernel loaded...
Loading ramdisk...
ramdisk loaded at 04200000, size: 12946 Kbytes
OF stdout device is: /vdevice/vty@30000000
Preparing to boot Linux version 2.6.32-29.el6.ppc64.debug (mockbuild@ppc-005.build.bos.redhat.com) (gcc version 4.4.4 20100518 (Red Hat 4.4.4-4) (GCC) ) #1 SMP Fri May 21 19:24:02 EDT 2010
Max number of cores passed to firmware: 0x0000000000000200
Calling ibm,client-architecture-support... done
command line: root=/dev/mapper/vg_ibmjs22vios01lp1-lv_root ro rd_LVM_LV=vg_ibmjs22vios01lp1/lv_root rd_LVM_LV=vg_ibmjs22vios01lp1/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us console=hvc0 rhgb quiet crashkernel=auto 
memory layout at init:
  memory_limit : 0000000000000000 (16 MB aligned)
  alloc_bottom : 0000000004eb0000
  alloc_top    : 0000000008000000
  alloc_top_hi : 0000000008000000
  rmo_top      : 0000000008000000
  ram_top      : 0000000008000000
instantiating rtas at 0x00000000074e0000... done
boot cpu hw idx 0000000000000000
starting cpu hw idx 0000000000000002... done
starting cpu hw idx 0000000000000004... done
starting cpu hw idx 0000000000000006... done
copying OF device tree...
Building dt strings...
Building dt structure...
Device tree strings 0x0000000004fc0000 -> 0x0000000004fc150c
Device tree struct  0x0000000004fd0000 -> 0x0000000004ff0000
Calling quiesce...
returning from prom_init
Kernel panic - not syncing: ERROR: Failed to allocate 0x4000 bytes below 0x10000000.

Rebooting in 180 seconds..

Expected results:
 System should boot as expected.

Additional info:
  I tried to duplicate this issue on a similar VIOS host, was unsuccessful.
Comment 2 Steve Best 2010-06-03 19:11:52 EDT
Jeff,

what system are you seeing this on?

-Steve
Comment 3 Jeff Burke 2010-06-03 20:28:47 EDT
Steve,
   This was seen on ibm-js22-vios-01-lp1.rhts.eng.bos.redhat.com

-Jeff
Comment 4 RHEL Product and Program Management 2010-06-07 12:01:03 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Note You need to log in before you can comment on or make changes to this bug.