Bug 595534 - SELinux is preventing /usr/lib/cups/backend/mfp "getattr" access on /proc/kallsyms.
SELinux is preventing /usr/lib/cups/backend/mfp "getattr" access on /pro...
Status: CLOSED DUPLICATE of bug 595533
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:bd0f2995cfa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 17:56 EDT by Vladimir
Modified: 2010-05-25 07:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-25 07:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir 2010-05-24 17:56:01 EDT
Summary:

SELinux is preventing /usr/lib/cups/backend/mfp "getattr" access on
/proc/kallsyms.

Detailed Description:

[mfp has a permissive type (cupsd_t). This access was not denied.]

SELinux denied access requested by mfp. It is not expected that this access is
required by mfp and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:system_map_t:s0
Target Objects                /proc/kallsyms [ file ]
Source                        mfp
Source Path                   /usr/lib/cups/backend/mfp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-92.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.9-67.fc12.i686.PAE
                              #1 SMP Sat Feb 27 09:42:55 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Sun 07 Mar 2010 10:04:07 PM EST
Last Seen                     Sun 07 Mar 2010 10:04:07 PM EST
Local ID                      c99426cc-cd62-46fa-96a3-d0bea456ece8
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1268017447.459:23341): avc:  denied  { getattr } for  pid=2778 comm="mfp" path="/proc/kallsyms" dev=proc ino=4026531968 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:system_map_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1268017447.459:23341): arch=40000003 syscall=195 success=yes exit=0 a0=6da72c a1=bfbdd97c a2=9beff4 a3=3 items=0 ppid=1071 pid=2778 auid=4294967295 uid=4 gid=7 euid=4 suid=4 fsuid=4 egid=7 sgid=7 fsgid=7 tty=(none) ses=4294967295 comm="mfp" exe="/usr/lib/cups/backend/mfp" subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,mfp,cupsd_t,system_map_t,file,getattr
audit2allow suggests:

#============= cupsd_t ==============
allow cupsd_t system_map_t:file getattr;
Comment 1 Miroslav Grepl 2010-05-25 07:53:03 EDT

*** This bug has been marked as a duplicate of bug 595533 ***

Note You need to log in before you can comment on or make changes to this bug.