Bug 595539 - SELinux is preventing /sbin/modprobe "search" access on /lib/modules.
SELinux is preventing /sbin/modprobe "search" access on /lib/modules.
Status: CLOSED DUPLICATE of bug 595535
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:ebee695ed7f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 18:02 EDT by Vladimir
Modified: 2010-05-25 04:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-25 04:53:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir 2010-05-24 18:02:28 EDT
Summary:

SELinux is preventing /sbin/modprobe "search" access on /lib/modules.

Detailed Description:

[modprobe has a permissive type (cupsd_t). This access was not denied.]

SELinux denied access requested by modprobe. It is not expected that this access
is required by modprobe and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:modules_object_t:s0
Target Objects                /lib/modules [ dir ]
Source                        modprobe
Source Path                   /sbin/modprobe
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           module-init-tools-3.9-4.fc12
Target RPM Packages           filesystem-2.4.30-2.fc12
Policy RPM                    selinux-policy-3.6.32-92.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.9-67.fc12.i686.PAE
                              #1 SMP Sat Feb 27 09:42:55 UTC 2010 i686 i686
Alert Count                   3
First Seen                    Sun 07 Mar 2010 10:04:07 PM EST
Last Seen                     Sun 07 Mar 2010 10:04:07 PM EST
Local ID                      ea383f00-eb18-4ba0-abee-fd5b03e813e0
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1268017447.523:23346): avc:  denied  { search } for  pid=2787 comm="modprobe" name="modules" dev=sda9 ino=122644 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:modules_object_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1268017447.523:23346): avc:  denied  { read } for  pid=2787 comm="modprobe" name="modules.dep.bin" dev=sda9 ino=953399 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:modules_dep_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1268017447.523:23346): avc:  denied  { open } for  pid=2787 comm="modprobe" name="modules.dep.bin" dev=sda9 ino=953399 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:modules_dep_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1268017447.523:23346): arch=40000003 syscall=5 success=yes exit=5 a0=84511f0 a1=0 a2=1b6 a3=805b429 items=0 ppid=2778 pid=2787 auid=4294967295 uid=4 gid=7 euid=4 suid=4 fsuid=4 egid=7 sgid=7 fsgid=7 tty=(none) ses=4294967295 comm="modprobe" exe="/sbin/modprobe" subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,modprobe,cupsd_t,modules_object_t,dir,search
audit2allow suggests:

#============= cupsd_t ==============
allow cupsd_t modules_dep_t:file { read open };
allow cupsd_t modules_object_t:dir search;
Comment 1 Miroslav Grepl 2010-05-25 04:53:24 EDT

*** This bug has been marked as a duplicate of bug 595535 ***

Note You need to log in before you can comment on or make changes to this bug.