Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 595557 - prelink launch
Summary: prelink launch
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: prelink
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 00:36 UTC by Fabrício Godoy
Modified: 2010-05-25 12:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 118522
Environment:
Last Closed: 2010-05-25 07:46:26 UTC
Type: ---


Attachments (Terms of Use)

Description Fabrício Godoy 2010-05-25 00:36:09 UTC
Every time that prelink launches my computer run slow.
I think that this can be solved by three ways: code optimization, less priority or show an alert to user.

Comment 1 Pedro Fernandes Macedo 2010-05-25 07:20:46 UTC
Please dont randomly add people to CC. I was only adding details to the original bug you cloned as I was seeing it as well. 

--
Pmacedo

Comment 2 Jakub Jelinek 2010-05-25 07:46:26 UTC
1) massive code optimizations have been done already in the past, and, more importantly, the /etc/cron.daily/prelink script changed, so that most of the days it either doesn't invoke prelink at all (if rpm database hasn't changed since last run, prelink is invoked by default only every week, not every day) or invokes prelink in quick mode (which just checks timestamps rather than actually reading all libraries/binaries to see if they have actually changed.  Unless glibc or some other library with thousands of binaries that link against it is upgraded, even quick mode shouldn't last longer than a minute or two.
So, if prelink is too slow on your box, either you have very small amount of memory, or very slow disk, or encrypted root partition, in each case the problem is in disk IO.

2) prelink runs under 
renice +19 -p $$
so it is very low priority job

3) I doubt anyone but very few people would appreciate something like that.  That is only going to annoy users.

Comment 3 Fabrício Godoy 2010-05-25 12:22:20 UTC
1) I have 2 GB RAM, 1 TB SATA II HD and none of partitions are encrypted.
I don't know if make difference but I have a lot of "devel" packages.
My PC do not goes too slow but HD works so much.
We should not think about weak computers?

2) Ok.

3) I agree.


Note You need to log in before you can comment on or make changes to this bug.