Bug 595604 - textmode: Pressing ok on not enough freespace dialog after autopart gives traceback
Summary: textmode: Pressing ok on not enough freespace dialog after autopart gives tra...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Martin Banas
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 07:27 UTC by Hans de Goede
Modified: 2010-07-02 20:50 UTC (History)
2 users (show)

Fixed In Version: anaconda-13.21.47-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 20:50:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2010-05-25 07:27:23 UTC
The summary pretty much says it all, when one gets
a "not enough freespace dialog" in a textmode install and then presses ok,
the next thing that happens is a traceback.

For the traceback see:
https://bugzilla.redhat.com/attachment.cgi?id=416112

Which is part of bug 591469, which is used for tracking the cause of (in this case wrongly) getting the not enough freespace dialog.

Comment 1 RHEL Product and Program Management 2010-05-25 07:36:18 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Chris Lumens 2010-05-25 13:49:41 UTC
anaconda 13.21.45 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/text.py", line 595, in run
    (file, classNames) = stepToClasses[step]
  File "/usr/bin/anaconda", line 1107, in <module>
    anaconda.intf.run(anaconda)
KeyError: 'partition'

Comment 4 Chris Lumens 2010-05-25 14:11:35 UTC
I think all that's needed here is to cherry-pick 0982f94dc987adc3b6aa4634a3150a7ba01d8229.

Comment 6 Martin Banas 2010-06-03 10:42:29 UTC
Verified with build RHEL6.0-20100531.1, anaconda-13.21.48-1.el6. Following traceback is no longer displayed, user is able to "Write changes to disk" or "Go back".. There's another traceback after user selects "Write changes to disk", but it's different issue (bug 599484).

I'm closing this bug as VERIFIED.

Comment 7 releng-rhel@redhat.com 2010-07-02 20:50:18 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.