Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 595705 - kdump on Intel,IDE kvm guest: [sda] Unhandled error code
kdump on Intel,IDE kvm guest: [sda] Unhandled error code
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: chellwig@redhat.com
Red Hat Kernel QE team
:
Depends On:
Blocks: 524819 591876
  Show dependency treegraph
 
Reported: 2010-05-25 08:30 EDT by Qian Cai
Modified: 2010-11-10 13:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When triggering kdump on an Intel SMP guest with IDE device, the kdump process was blocked with errors.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 21:02:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest xml (1.76 KB, application/xml)
2010-05-25 08:30 EDT, Qian Cai
no flags Details

  None (edit)
Description Qian Cai 2010-05-25 08:30:26 EDT
Created attachment 416377 [details]
guest xml

Description of problem:
Occasionally, when triggering kdump on an Intel SMP guest with IDE device, the kdump process was blocked here with errors,

Creating block device sda
Making device-mapper control node
sd 0:0:0:0: [sda] Unhandled error code
sd 0:0:0:0: [sda] Result: hostbyte=DID_OK driverbyte=DRIVER_TIMEOUT
sd 0:0:0:0: [sda] CDB: Read(10): 28 00 00 ff ff f0 00 00 02 00
end_request: I/O error, dev sda, sector 16777200
ata1: lost interrupt (Status 0x50)
sd 0:0:0:0: [sda] Unhandled error code
sd 0:0:0:0: [sda] Result: hostbyte=DID_OK driverbyte=DRIVER_TIMEOUT
sd 0:0:0:0: [sda] CDB: Read(10): 28 00 00 ff ff ff 00 00 01 00
end_request: I/O error, dev sda, sector 16777215

Version-Release number of selected component (if applicable):
RHEL6.0-20100524.n.0
kernel-2.6.32-28.el6
qemu-kvm-0.12.1.2-2.62.el6

How reproducible:
around 50%

Steps to Reproduce:
1. installed a RHEL6 guest.
2. boot the guest using the attached xml.
3. setup kdump to the IDE disk and trigger it via sysrq-c
  
Actual results:
kdump progress hung due to disk errors,

Expected results:
Successfully saved a vmcore.
Comment 1 Qian Cai 2010-05-28 04:05:46 EDT
Even on UP guest, the driver may lost sometimes during the kdump kernel,
md: Waiting for all devices to be available before autodetect
md: If you don't use raid, use raid=noautodetect
md: Autodetecting RAID arrays.
md: Scanned 0 and added 0 devices.
md: autorun ...
md: ... autorun DONE.
VFS: Cannot open root device "mapper/VolGroup-lv_root" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Pid: 1, comm: swapper Not tainted 2.6.32-30.el6.x86_64 #1
Call Trace:
 [<ffffffff814d3671>] panic+0x78/0x137
 [<ffffffff818d9311>] mount_block_root+0x1ea/0x29e
 [<ffffffff818d941b>] mount_root+0x56/0x5a
 [<ffffffff818d958f>] prepare_namespace+0x170/0x1a9
 [<ffffffff818d885e>] kernel_init+0x28c/0x29c
 [<ffffffff810141ca>] child_rip+0xa/0x20
 [<ffffffff818d85d2>] ? kernel_init+0x0/0x29c
 [<ffffffff810141c0>] ? child_rip+0x0/0x20
Comment 2 Qian Cai 2010-06-03 10:07:34 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
When triggering kdump on an Intel SMP guest with IDE device, the kdump process was blocked with errors.
Comment 3 chellwig@redhat.com 2010-06-11 13:42:11 EDT
(In reply to comment #1)
> Even on UP guest, the driver may lost sometimes during the kdump kernel,
> md: Waiting for all devices to be available before autodetect
> md: If you don't use raid, use raid=noautodetect
> md: Autodetecting RAID arrays.
> md: Scanned 0 and added 0 devices.
> md: autorun ...
> md: ... autorun DONE.
> VFS: Cannot open root device "mapper/VolGroup-lv_root" or unknown-block(0,0)
> Please append a correct "root=" boot option; here are the available partitions:
> Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
> Pid: 1, comm: swapper Not tainted 2.6.32-30.el6.x86_64 #1
> Call Trace:
>  [<ffffffff814d3671>] panic+0x78/0x137
>  [<ffffffff818d9311>] mount_block_root+0x1ea/0x29e
>  [<ffffffff818d941b>] mount_root+0x56/0x5a
>  [<ffffffff818d958f>] prepare_namespace+0x170/0x1a9
>  [<ffffffff818d885e>] kernel_init+0x28c/0x29c
>  [<ffffffff810141ca>] child_rip+0xa/0x20
>  [<ffffffff818d85d2>] ? kernel_init+0x0/0x29c
>  [<ffffffff810141c0>] ? child_rip+0x0/0x20    

This is not related to ide code at all.  You're using a LVM for root, but don't appear to have an initramfs that can deal with it.

Note You need to log in before you can comment on or make changes to this bug.