Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 595706 - Running `condor_q -bet` results in 'Segmentation fault (core dumped)'
Running `condor_q -bet` results in 'Segmentation fault (core dumped)'
Status: CLOSED DUPLICATE of bug 571804
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
1.2
All Linux
medium Severity medium
: 1.3
: ---
Assigned To: Matthew Farrellee
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-25 08:32 EDT by Jon Thomas
Modified: 2010-05-25 13:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-25 13:34:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Thomas 2010-05-25 08:32:17 EDT
Description of problem:
=======================
RHEL 5.4
Condor Version: 7.4.3-0.11.el5


There are actually 2 issues but they both seem related to each other...

Running `condor_q -bet` on host #1 results in "Segmentation fault (core dumped)"

Running `condor_q -bet` on any other hosts while there are MPI jobs in the queue results in the following output:

error: no operator/attribute found
error: found NULL ptr in expr
error: problem with ExprToProfile
error in ExprToMultiProfile

error in AnalyzeAttributes

---
2770.000:  Run analysis summary.  Of 12 machines,
     0 are rejected by your job's requirements
     4 reject your job because of their own requirements
     0 match but are serving users with a better priority in the pool
     8 match but reject the job for unknown reasons
     0 match but will not currently preempt their existing job
     0 match but are currently offline
     0 are available to run your job
error: no operator/attribute found
error: found NULL ptr in expr
error: problem with ExprToProfile
error in ExprToMultiProfile

error in AnalyzeAttributes

Regardless of the different job types in the queue on machine #1 always segfaults...


Core was generated by `condor_q -bet'.
Program terminated with signal 11, Segmentation fault.

(gdb) bt
#0  0x000000317209c8c8 in std::basic_string<char, std::char_traits<char>, std::allocator<char> >::basic_string () from /usr/lib64/libstdc++.so.6
#1  0x000000000048495f in std::_Rb_tree<std::string, std::string, std::_Identity<std::string>, classad::CaseIgnLTStr, std::allocator<std::string> >::_M_insert
   ()
#2  0x0000000000484a4a in std::_Rb_tree<std::string, std::string, std::_Identity<std::string>, classad::CaseIgnLTStr, std::allocator<std::string> >::insert_unique ()
#3  0x00000000004836d2 in AddExplicitTargets ()
#4  0x00000000004654da in ClassAdAnalyzer::MakeResourceGroup ()
#5  0x000000000046e19f in ClassAdAnalyzer::AnalyzeJobAttrsToBuffer ()
#6  0x0000000000461e35 in ?? ()
#7  0x000000000046472b in ?? ()
#8  0x0000000000463d25 in main ()
Comment 1 Luigi Toscano 2010-05-25 08:50:16 EDT
It reminds me of BZ595706 - isn't this the same bug?
Comment 2 Matthew Farrellee 2010-05-25 13:28:53 EDT
s/../BZ571804/
Comment 3 Matthew Farrellee 2010-05-25 13:34:28 EDT

*** This bug has been marked as a duplicate of bug 571804 ***

Note You need to log in before you can comment on or make changes to this bug.