Bug 595730 - keyboard shortcuts don't work when drop down has focus
Summary: keyboard shortcuts don't work when drop down has focus
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-core
Version: 5.7
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Matthias Clasen
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 13:29 UTC by jason.m.close
Modified: 2010-05-27 01:23 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-27 01:23:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description jason.m.close 2010-05-25 13:29:35 UTC
Description of problem:
when a drop down has focus in an application (whether it is the terminal window, and you have clicked on 'Help' to see the drop down, or you are in Firefox and you have clicked the down arrow to see a browser's history), the keyboard mappings lose their ability until you have closed that drop down.  Alt+Tab becomes unresponsive, Ctrl+Alt+[Arrow] (switching desktops) stops working until you close the drop down by making a selection within it or selecting outside of that drop down area.

Version-Release number of selected component (if applicable):
All

How reproducible:
Always

Steps to Reproduce:
1.Open Terminal
2.Click 'Help' to expand the 'Help' menu, but leave the mouse/arrow/pointer above the word 'Help' so that it does not lose focus.
3.Press Alt+Tab to change applications
4.Observe that nothing happens
  
Actual results:
Keyboard mappings are frozen

Expected results:
The currently open drop down should lose focus (close/disappear), and keyboard mappings should work.

Additional info:
Seems to be unified across all applications.

Comment 1 Matthias Clasen 2010-05-27 01:23:41 UTC
This is deeply ingrained in the design of the window system, and essentially unfixable.


Note You need to log in before you can comment on or make changes to this bug.