Bug 59574 - RFE: rename ncurses4 into ncurses4-compat
RFE: rename ncurses4 into ncurses4-compat
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ncurses4 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-10 14:53 EST by Aleksey Nogin
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-10 14:53:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2002-02-10 14:53:25 EST
There is an inconsistency in the way backwards-compatibility packages are named.
Some (for example, compat-gcc and kde1-compat) have compat in their names and
some just have a number. IMHO, it's much better to use compat since that would
allow one to easily identify all the compat packages installed and remove them
once they are longer needed.

IMHO, it would be better if ncurses4 would be renamed into ncurses4-compat.
Comment 1 Bernhard Rosenkraenzer 2002-02-11 09:22:07 EST
I agree that it's not very consistant, but renaming the package now after it has
been called ncurses4 for the past 4 releases (and been a compat package all the
time) would be even more confusing.

(Besides, there's no real consistancy in the first place - look at e.g.
readline41, libpng10 or the whole slew of gnome compat libraries (gal7 and
friends).)

Note You need to log in before you can comment on or make changes to this bug.