Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 595753 - Anaconda no longer works with redirected methods
Anaconda no longer works with redirected methods
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-25 10:38 EDT by Mike McGrath
Modified: 2010-05-25 16:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-25 16:59:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McGrath 2010-05-25 10:38:26 EDT
Description of problem:
This worked in F12 but not in F13 (perhaps a urlgrabber difference?)  If you use our download.fedoraproject.org as your method, for example:

method=http://download.fedora.redhat.com/pub/fedora/linux/releases/13/Fedora/i386/os/

anaconda will fail to follow that redirect

Version-Release number of selected component (if applicable):

F13 gold.

How reproducible:

every time

Steps to Reproduce:
1.  append "method=http://download.fedora.redhat.com/pub/fedora/linux/releases/13/Fedora/i386/os/" to a F13 i386 install.
  
Actual results:

anaconda fails to download the install.img file

Expected results:

anaconda should download the install.img file

Additional info:
Comment 1 Chris Lumens 2010-05-25 11:28:22 EDT
I've got an install going right now using your above method= string that's downloading install.img.  It's true that we used to have a problem with redirects (libcurl does not follow them by default), but that should have been fixed for a while now.  Can you attach /tmp/anaconda.log (tty3) to this bug report so we have some more information to go on?
Comment 2 Mike McGrath 2010-05-25 16:59:04 EDT
I'm going to close this bug.  I think I had a string of unlucky attempts this morning (probably related to mirror overload in the release) because I can't reliably reproduce it now.

Note You need to log in before you can comment on or make changes to this bug.