Bug 59579 - Upgrade path does not find the existing install of 7.2
Upgrade path does not find the existing install of 7.2
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-10 15:19 EST by Sam Varshavchik
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2002-02-10 15:19:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205

Description of problem:
Started a Hampton beta1 pcmcia install on a laptop that dual boots 7.2 and
another OS.  Selected "upgrade".  Error: "You don't have any Linux partitions".



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start pcmcia install
2. Choose 'upgrade'

	

Actual Results:  Error message "You don't have any Linux partitions."

Expected Results:  A prompt to upgrade the Linux partition on /dev/hda7


Additional info:

fdisk:
isk /dev/hda: 128 heads, 63 sectors, 746 cylinders
Units = cylinders of 8064 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       131    528160+   b  Win95 FAT32
/dev/hda2           132       745   2475648    5  Extended
/dev/hda5           132       262    528160+   b  Win95 FAT32
/dev/hda6           263       275     52384+  83  Linux
/dev/hda7           276       702   1721632+  83  Linux
/dev/hda8           703       745    173344+  82  Linux swap


[root@laptop root]# cat /etc/fstab
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/hda8               swap                    swap    defaults        0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0
[root@laptop root]# mount
/dev/hda7 on / type ext3 (rw)
none on /proc type proc (rw)
/dev/hda6 on /boot type ext3 (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
none on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
Comment 1 Jay Turner 2002-03-19 14:37:21 EST
This is probably related to the partition table re-read bug we were seeing.  Are
you able to replicate with Beta 2?
Comment 2 Sam Varshavchik 2002-03-19 23:54:29 EST
I reinstalled RH 7.2, and tried to upgrade to beta2.  It worked.

Comment 3 Michael Fulbright 2002-03-26 12:31:27 EST
Deferring to future release.
Comment 4 Red Hat Bugzilla 2006-02-21 13:48:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.