Bug 595813 - virtio-blk doesn't handle barriers correctly
Summary: virtio-blk doesn't handle barriers correctly
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: beta
: ---
Assignee: Kevin Wolf
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 16:50 UTC by Kevin Wolf
Modified: 2013-01-09 22:37 UTC (History)
7 users (show)

Fixed In Version: qemu-kvm-0.12.1.2-2.68.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-17 12:29:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin Wolf 2010-05-25 16:50:48 UTC
Before issuing the barrier to the block driver we need to flush our oustanding queue of write requests, as the flush is supposed to be issued after them.

Comment 1 RHEL Product and Program Management 2010-05-25 17:16:14 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Lawrence Lim 2010-05-26 14:02:30 UTC
Could you please some suggestions on how we could verify this bug?

Comment 5 Kevin Wolf 2010-05-26 14:49:11 UTC
Your best bet is probably to put load on the file system and then cut off host
power. You might see some corruption then. But note that this fix is based on
code review, not on a concrete bug report.

Christoph, any better idea how to systematically provoke a failure without the
fix?

Comment 9 lihuang 2010-06-17 12:29:35 UTC
we have to test runner with virtio blk since -69.el6:
qemu-kvm-0.12.1.2-2.72.el6
https://tcms.engineering.redhat.com/run/10228/?from_plan=2104

qemu-kvm-0.12.1.2-2.69.el6
https://tcms.engineering.redhat.com/run/10185/?from_plan=2104

PASS.

setting to closed.


Note You need to log in before you can comment on or make changes to this bug.