Bug 595853 - [abrt] crash in font-manager-0.4.4-1.fc12: xmlutils.py:364:check_for_fm_req_dir:OSError: [Errno 13] Permission denied: '/home/gidmantas/.FontManager/config'
Summary: [abrt] crash in font-manager-0.4.4-1.fc12: xmlutils.py:364:check_for_fm_req_d...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: font-manager (Show other bugs)
(Show other bugs)
Version: 12
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Jean-Francois Saucier
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a348de6d
Keywords:
: 598141 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 19:04 UTC by Gidmantas
Modified: 2010-07-23 02:33 UTC (History)
2 users (show)

Fixed In Version: font-manager-0.5.5.4-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-23 02:24:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (728 bytes, text/plain)
2010-05-25 19:04 UTC, Gidmantas
no flags Details

Description Gidmantas 2010-05-25 19:04:49 UTC
abrt 1.0.9 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/font-manager
component: font-manager
executable: /usr/bin/font-manager
kernel: 2.6.32.11-99.fc12.i686.PAE
package: font-manager-0.4.4-1.fc12
reason: xmlutils.py:364:check_for_fm_req_dir:OSError: [Errno 13] Permission denied: '/home/gidmantas/.FontManager/config'
release: Fedora release 12 (Constantine)

backtrace
-----
xmlutils.py:364:check_for_fm_req_dir:OSError: [Errno 13] Permission denied: '/home/gidmantas/.FontManager/config'

Traceback (most recent call last):
  File "/usr/bin/font-manager", line 87, in <module>
    main()
  File "/usr/bin/font-manager", line 79, in main
    FontManager()
  File "/usr/share/font-manager/main.py", line 78, in __init__
    xmlutils.check_install()
  File "/usr/share/font-manager/xmlutils.py", line 343, in check_install
    check_for_fm_req_dir()
  File "/usr/share/font-manager/xmlutils.py", line 364, in check_for_fm_req_dir
    os.mkdir(DIR)
OSError: [Errno 13] Permission denied: '/home/gidmantas/.FontManager/config'

Local variables in innermost frame:
DIR: '/home/gidmantas/.FontManager/config'

How to reproduce
-----
1. it crashes on logon
2.
3.

Comment 1 Gidmantas 2010-05-25 19:04:51 UTC
Created attachment 416479 [details]
File: backtrace

Comment 2 Jean-Francois Saucier 2010-05-27 14:06:13 UTC
Thank you for reporting this to me.

Can you provide me the output of this command in a terminal :

ls -la /home/gidmantas/.FontManager


There is a new version of Font Manager out so I will try to package it and run the tests on this version. If everything goes well, I will push it as an update soon.

Comment 3 Gidmantas 2010-05-31 14:37:59 UTC
This is the output of ls -la /home/gidmantas/.FontManager

ls: cannot access /home/gidmantas/.FontManager/logs: Permission denied
ls: cannot access /home/gidmantas/.FontManager/Library: Permission denied
ls: cannot access /home/gidmantas/.FontManager/.: Permission denied
ls: cannot access /home/gidmantas/.FontManager/0.4: Permission denied
ls: cannot access /home/gidmantas/.FontManager/config: Permission denied
ls: cannot access /home/gidmantas/.FontManager/..: Permission denied
ls: cannot access /home/gidmantas/.FontManager/db: Permission denied
ls: cannot access /home/gidmantas/.FontManager/collections: Permission denied
total 0
d????????? ? ? ? ?            ? .
d????????? ? ? ? ?            ? ..
-????????? ? ? ? ?            ? 0.4
d????????? ? ? ? ?            ? collections
d????????? ? ? ? ?            ? config
d????????? ? ? ? ?            ? db
d????????? ? ? ? ?            ? Library
d????????? ? ? ? ?            ? logs

Comment 4 Jean-Francois Saucier 2010-05-31 15:08:59 UTC
*** Bug 598141 has been marked as a duplicate of this bug. ***

Comment 5 Gidmantas 2010-05-31 15:10:36 UTC
Package: font-manager-0.4.4-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. crash on startup
2.
3.

Comment 6 Jean-Francois Saucier 2010-05-31 15:12:44 UTC
Can you give me the same output of ls -la /home/gidmantas/.FontManager with the root user please?

Is your home directory on a nfs share or some other shared storage? Is your home directory encrypted?


Thank you.

Comment 7 Gidmantas 2010-06-07 18:38:49 UTC
Package: font-manager-0.4.4-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Crash on startup
2.
3.

Comment 8 Gidmantas 2010-06-14 19:15:22 UTC
Package: font-manager-0.4.4-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Crash on startup
2.
3.

Comment 9 Jean-Francois Saucier 2010-06-14 20:46:16 UTC
Hi,

Thank you for reporting this bug but can you please answer the question I ask about your setup? Without this information I can't fix or try to reproduce the bug on my system.


Thanks.

Comment 10 Gidmantas 2010-06-16 18:48:52 UTC
[root@gidmantas Documents]# ls -la /home/gidmantas/.FontManager
total 40
drwxrwxrwx   7 gidmantas root       4096 May 20 22:19 .
drwxrwxrwx. 67 gidmantas gidmantas 12288 Jun 16 20:37 ..
-rwxrwxrwx   1 gidmantas root         18 May 20 22:17 0.4
drwsrwsrwx   2 gidmantas root       4096 May 20 22:46 collections
drwsrwsrwx   2 gidmantas root       4096 May 20 22:17 config
drwsrwsrwx   2 gidmantas root       4096 May 20 22:17 db
drwsrwsrwx   4 gidmantas root       4096 May 20 22:03 Library
drwsrwsrwx   2 gidmantas root       4096 May 20 22:17 logs

Comment 11 Jean-Francois Saucier 2010-06-17 14:51:39 UTC
This is a really weird permission set for a folder in your home directory.

I would like you to run this command as root if you want :

chgrp -R gidmantas /home/gidmantas/.FontManager


This will remove root from being the group owner.

After this, you should set sane permission for the files and folders inside with :

find /home/gidmantas/.FontManager -type d -exec chmod 775 {} \;
find /home/gidmantas/.FontManager -type f -exec chmod 664 {} \;


I don't know how root became the group owner in your case, and how the permissions got set wrong but this is the first time I see that happen with font-manager.

You should also look at the permission of your home directory as it let anyone read and write to it, but this is outside the scope of this bug. If you have any question about this, I welcome you to ask at fedoraforum.org.

Thank you.

Comment 12 Fedora Update System 2010-07-08 13:59:56 UTC
font-manager-0.5.5.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/font-manager-0.5.5.4-1.fc13

Comment 13 Fedora Update System 2010-07-08 14:12:05 UTC
font-manager-0.5.5.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/font-manager-0.5.5.4-1.fc12

Comment 14 Fedora Update System 2010-07-08 18:21:05 UTC
font-manager-0.5.5.4-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update font-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/font-manager-0.5.5.4-1.fc13

Comment 15 Fedora Update System 2010-07-08 18:27:32 UTC
font-manager-0.5.5.4-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update font-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/font-manager-0.5.5.4-1.fc12

Comment 16 Fedora Update System 2010-07-23 02:24:41 UTC
font-manager-0.5.5.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2010-07-23 02:33:07 UTC
font-manager-0.5.5.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.