Bug 595880 - gtk-vnc should support qemu/kvm VNC audio extension
gtk-vnc should support qemu/kvm VNC audio extension
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk-vnc (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
: 477955 (view as bug list)
Depends On:
Blocks: 508317 F14VirtTarget
  Show dependency treegraph
 
Reported: 2010-05-25 16:30 EDT by Cole Robinson
Modified: 2013-01-08 05:38 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-08 15:02:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2010-05-25 16:30:39 EDT
This is a bug to track qemu/kvm VNC audio support in gtk-vnc. Currently, getting audio to work with VMs in fedora is total crack; seamless out of the box support with VNC would be really slick.

Older info about a similar Fedora feature:

http://fedoraproject.org/wiki/Features/VirtVNCResourceTunnel
Comment 1 Cole Robinson 2010-06-30 12:04:28 EDT
*** Bug 477955 has been marked as a duplicate of this bug. ***
Comment 2 Gilboa Davara 2010-06-30 14:34:10 EDT
Thanks for updating the bug.
Is this feature targeted for inclusion in F14?

- Gilboa
Comment 3 Cole Robinson 2010-06-30 15:10:56 EDT
Not explicitly, but AFAIU the gtk-vnc code is mostly complete, it just had some issues with audio skipping. I'm hoping to dust off the code and at least get it into F14, even if the result is less than perfect.
Comment 4 Gilboa Davara 2010-07-01 14:10:15 EDT
Is it testable in any form under F13 (Even by rebuilding rawhide SRPMs)?
Will it work with qemu-kvm proper (Read: without virt-manager)?

Thanks again.
Comment 5 Bug Zapper 2010-07-30 07:42:34 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Grant Williamson 2010-09-03 08:24:57 EDT
Has this code been added to the latest f14 test build i.e. gtk-vnc-0.4.1-6,
and will it work in conjunction with virt-manager?

Thanks.

If the patch has not been added, is there a git repo, where I can pull it down, thanks.
Comment 7 Matt Domsch 2010-09-14 23:45:00 EDT
I'd like to propose this for F14Target.  I don't know if that's possible at this point, or if it's possible to get the changes in time, but having functional sound in guest VMs would certainly make Fedora appear more polished.  Lack of functional guest sound makes it appear unpolished.
Comment 8 David Ayers 2011-01-22 02:25:29 EST
Could we get a status update on this issue to see if it would make sense to work on a patch independently?

Thanks!
David
Comment 9 Daniel Berrange 2012-02-08 15:02:22 EST
This is available in the GTK-VNC in Fedora 17. I don't have plans to backport to older Fedora.
Comment 10 Cole Robinson 2012-02-08 18:05:08 EST
Cool, congrats on finally landing it. Is there anything we need to do in virt-manager to enable this or does it just happen automagically?
Comment 11 Daniel Berrange 2012-02-09 05:21:43 EST
No it isn't automatic, since you have to pick an audio output target - currently PulseAudio is the only option.

The slight complication for virt-manager, is that to access this functionality you'd need to by using the GObject introspection based bindings, instead of the legacy python binding.

API-wise they are a pretty close match, so I think it ought to be possible to make the code work with both the legacy & Introspection based bindings at the same time. Obviously audio would only be supported for the latter.  I'll try and do a patch for virt-manager, since this isn't really documented
Comment 12 Cole Robinson 2012-02-09 11:04:41 EST
Can we mix and match gobject introspection with gtk2? I tried to port virt-manager to vte3 with introspected bindings and gtk complained with an error to that effect, which sucks. But end result is I'll be looking into a gtk3 port sooner rather than later.
Comment 13 Daniel Berrange 2012-02-09 11:22:25 EST
Yes, introspection is independent of the GTK version, so you can still use it with Gtk2.
Comment 14 Daniel Berrange 2012-02-16 07:09:49 EST
> > Can we mix and match gobject introspection with gtk2?
> Yes, introspection is independent of the GTK version, so you can still use it
> with Gtk2.

Fate conspires against us. While it is possible to mix it at a C level, the life isn't so nice at the Python level.  The Pygobject bindings will refuse to allow mixing of the traditional manual bindings, with the new GOBject bindings. The upshot is we can't use the GTK-VNC GObject dynamic bindings, without converting the rest of virt-manager to also use the new GObject bindings :-(

Seems like the only options will be to switch virt-manager master branch wholesale to dynamic GObject bindings, at which point you might as well use GTK3 too. For any platforms predating Fedora 16, we'd need to maintain some kind of "stable branch" for the previous virt-manager release.

Note You need to log in before you can comment on or make changes to this bug.