Bug 595890 - If search filter includes DN syntax attr and its value containing escapes, the search does not find the expected entries
Summary: If search filter includes DN syntax attr and its value containing escapes, th...
Status: CLOSED NOTABUG
Alias: None
Product: 389
Classification: Retired
Component: Directory Server   
(Show other bugs)
Version: 1.2.6
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Noriko Hosoi
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 20:53 UTC by Noriko Hosoi
Modified: 2015-01-04 23:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-25 22:11:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Noriko Hosoi 2010-05-25 20:53:46 UTC
Description of problem:
Sample entry:
dn: CN=Lu\C4\8Di\C4\87, dc=bug199923,dc=com
objectClass: top
objectClass: person
objectClass: organizationalPerson
objectClass: inetOrgPerson
sn: I18n
uid: I18n
userPassword: I18n
seeAlso: CN=Lu\C4\8Di\C4\87, dc=bug199923,dc=com

If the value in the filter is made from real characters, it returns the expected entry:
ldapsearch -b "CN=Lu\C4\8Di\C4\87, dc=bug199923,dc=com" -e 'seeAlso=CN=Lučić,dc=bug199923,dc=com' seeAlso
dn: CN=Lučić,dc=bug199923,dc=com
seeAlso: CN=Lučić,dc=bug199923,dc=com

On the other hand, if it contains the escaped representation as follows, it returns none:
ldapsearch -1 -h kiki.usersys.redhat.com -p 10389 -D 'cn=directory manager' -w Secret123 -b "CN=Lu\C4\8Di\C4\87, dc=bug199923,dc=com" -e 'seeAlso=CN=Luči\\C4\\87, dc=bug199923,dc=com'

Comment 1 Noriko Hosoi 2010-05-25 22:11:16 UTC
It's a test problem.  Not a bug...


Note You need to log in before you can comment on or make changes to this bug.