Bug 59590 - RFE: proposal for speeding up CD-ROM installs
RFE: proposal for speeding up CD-ROM installs
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-10 17:15 EST by Chris Ricker
Modified: 2007-03-26 23:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-07 14:59:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-02-10 17:15:19 EST
When doing a CD-ROM install, package installation works something like this (I'm
basing this on the system sounds alone -- I'll go poke the anaconda source in a
minute to see what's *really* happening ;-):

1.  CD-ROM spins up, hard drive is idle
2.  package is transferred to hard drive from CD-ROM
3.  CD-ROM spins down
4.  package is installed

(3 and 4 are more-or-less simultaneous)

Since modern fast CD-ROMs take a long time to spin up and down, the end result
is that a lot of time is wasted....

If anaconda transferred multiple packages at once from CD-ROM and staged them
temporarily, CD install would be faster
Comment 1 Michael Fulbright 2002-02-11 10:53:45 EST
Matt any idea on how to keep the drive motor running?
Comment 2 Matt Wilson 2002-02-11 12:52:58 EST
Other distros have done a "while /bin/true; read from /dev/cdrom > /dev/null;
done" for this...
Comment 3 Michael Fulbright 2002-03-26 12:30:58 EST
Deferring to future release.
Comment 4 Chris Ricker 2002-06-06 00:09:05 EDT
Now that it's new release time I'm reopening this (note:  I've not yet gotten to
try an install.  If the new beta is already doing this, then please close it
appropriately)
Comment 5 Michael Fulbright 2003-03-07 14:59:39 EST
We have not had any further complaints about CDROM installs so I do not judge
this change is necessary.

Note You need to log in before you can comment on or make changes to this bug.