Bug 595911 - Document APIs that have changed in a breaking way in JON2.4
Document APIs that have changed in a breaking way in JON2.4
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Documentation (Show other bugs)
unspecified
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Deon Ballard
Andrew Ross
:
Depends On:
Blocks: jon24-docs
  Show dependency treegraph
 
Reported: 2010-05-25 17:57 EDT by Charles Crouch
Modified: 2015-02-01 18:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-10 20:22:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2010-05-25 17:57:28 EDT
Right now the only breaking api change seems to be around 
ChannelManager going to RepoManager, and presumably associated domain objects were also changed.

More details are:
http://rhq-project.org/display/RHQ/API+Changes+Between+JOPR+2.3.1+And+RHQ+3.0.0
Comment 2 Deon Ballard 2010-07-12 19:08:33 EDT
I made a section in the release notes for "structural changes" here:
http://elladeon.fedorapeople.org/jon-drafts/3.0/rel-notes/changes-in-behavior.html

I also updated the names of a couple of the variables in http://elladeon.fedorapeople.org/jon-drafts/3.0/cli/Working_with_the_CLI-Implicit_Variables.html.
Comment 3 Corey Welton 2010-08-18 15:39:31 EDT
Verified.

Note You need to log in before you can comment on or make changes to this bug.