Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 595916 - Exception: fstab entry /dev/sda9 is malformed: scanned format (ext4) differs from fstab format (ext3)
Summary: Exception: fstab entry /dev/sda9 is malformed: scanned format (ext4) differs ...
Keywords:
Status: CLOSED DUPLICATE of bug 577260
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:931555a7728e3a916...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 22:11 UTC by Pavel Holica
Modified: 2010-12-04 13:08 UTC (History)
23 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-25 22:52:49 UTC
Type: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (262.83 KB, text/plain)
2010-05-25 22:11 UTC, Pavel Holica
no flags Details
Attached traceback automatically from anaconda. (466.48 KB, text/plain)
2010-05-26 17:22 UTC, Petros Athanassopoulos
no flags Details
Attached traceback automatically from anaconda. (325.63 KB, text/plain)
2010-05-26 20:56 UTC, Edson Dino Salvati
no flags Details
Attached traceback automatically from anaconda. (280.21 KB, text/plain)
2010-05-27 19:36 UTC, dtdraganov
no flags Details
Attached traceback automatically from anaconda. (313.89 KB, text/plain)
2010-05-31 12:15 UTC, Vyhnalek Petr
no flags Details
Attached traceback automatically from anaconda. (267.25 KB, text/plain)
2010-05-31 14:43 UTC, Denis Arnaud
no flags Details
Attached traceback automatically from anaconda. (291.88 KB, text/plain)
2010-05-31 14:45 UTC, Petr Pisar
no flags Details
Attached traceback automatically from anaconda. (310.42 KB, text/plain)
2010-06-01 12:48 UTC, Vyhnalek Petr
no flags Details
Attached traceback automatically from anaconda. (251.95 KB, text/plain)
2010-06-01 16:59 UTC, kruvalig
no flags Details
Attached traceback automatically from anaconda. (252.12 KB, text/plain)
2010-06-01 17:01 UTC, kruvalig
no flags Details
Attached traceback automatically from anaconda. (158.92 KB, text/plain)
2010-06-05 22:11 UTC, Arthur
no flags Details
Attached traceback automatically from anaconda. (159.23 KB, text/plain)
2010-06-08 16:44 UTC, Arthur
no flags Details
Attached traceback automatically from anaconda. (265.65 KB, text/plain)
2010-06-09 16:33 UTC, Ahmet
no flags Details
Attached traceback automatically from anaconda. (206.27 KB, text/plain)
2010-06-11 20:26 UTC, machnik.pawel
no flags Details
Attached traceback automatically from anaconda. (310.19 KB, text/plain)
2010-06-22 01:56 UTC, Diogo
no flags Details
Attached traceback automatically from anaconda. (184.91 KB, text/plain)
2010-06-24 18:45 UTC, Tomasz Ostrowski
no flags Details
Attached traceback automatically from anaconda. (178.39 KB, text/plain)
2010-06-26 17:01 UTC, Prabhakaran
no flags Details
Attached traceback automatically from anaconda. (396.44 KB, text/plain)
2010-08-18 20:56 UTC, Leo Bosnjak
no flags Details
Attached traceback automatically from anaconda. (347.28 KB, text/plain)
2010-08-25 06:57 UTC, David Kovalsky
no flags Details
Attached traceback automatically from anaconda. (314.25 KB, text/plain)
2010-08-25 21:16 UTC, mrblack
no flags Details
Attached traceback automatically from anaconda. (226.17 KB, text/plain)
2010-08-31 13:57 UTC, Chris Schanzle
no flags Details
Attached traceback automatically from anaconda. (218.88 KB, text/plain)
2010-09-07 15:13 UTC, megareg
no flags Details
Attached traceback automatically from anaconda. (239.79 KB, image/jpeg)
2010-09-17 14:50 UTC, Morgan McBee
no flags Details
Attached traceback automatically from anaconda. (177.96 KB, text/plain)
2010-09-18 05:43 UTC, patchesthecaveman
no flags Details
Attached traceback automatically from anaconda. (275.28 KB, text/plain)
2010-11-05 21:48 UTC, zimon
no flags Details
Attached traceback automatically from anaconda. (348.77 KB, text/plain)
2010-12-04 13:07 UTC, shakka.by
no flags Details
Comment (243.47 KB, text/plain)
2010-09-17 15:03 UTC, Morgan McBee
no flags Details

Description Pavel Holica 2010-05-25 22:11:35 UTC
The following was filed automatically by anaconda:
anaconda 13.42 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/__init__.py", line 1721, in parseFSTab
    raise Exception("fstab entry %s is malformed: %s" % (devspec, e))
  File "/usr/lib/anaconda/storage/__init__.py", line 1316, in mountExistingSystem
    fsset.parseFSTab()
  File "/usr/lib/anaconda/upgrade.py", line 172, in upgradeMountFilesystems
    mountExistingSystem(anaconda, anaconda.upgradeRoot[0], allowDirty = 0)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 228, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1346, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/gui.py", line 1522, in setup_window
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1532, in run
    self.setup_window(runres)
  File "/usr/lib/anaconda/gui.py", line 1263, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 1223, in <module>
    anaconda.intf.run(anaconda)
Exception: fstab entry /dev/sda9 is malformed: scanned format (ext4) differs from fstab format (ext3)

Comment 1 Pavel Holica 2010-05-25 22:11:41 UTC
Created attachment 416573 [details]
Attached traceback automatically from anaconda.

Comment 2 Chris Lumens 2010-05-25 22:52:49 UTC

*** This bug has been marked as a duplicate of bug 577260 ***

Comment 3 Petros Athanassopoulos 2010-05-26 17:22:50 UTC
Created attachment 416940 [details]
Attached traceback automatically from anaconda.

Comment 4 Edson Dino Salvati 2010-05-26 20:56:43 UTC
Created attachment 417028 [details]
Attached traceback automatically from anaconda.

Comment 5 dtdraganov 2010-05-27 19:36:40 UTC
Created attachment 417360 [details]
Attached traceback automatically from anaconda.

Comment 6 Vyhnalek Petr 2010-05-31 12:15:42 UTC
Created attachment 418279 [details]
Attached traceback automatically from anaconda.

Comment 7 Denis Arnaud 2010-05-31 14:43:05 UTC
Created attachment 418319 [details]
Attached traceback automatically from anaconda.

Comment 8 Petr Pisar 2010-05-31 14:45:33 UTC
Created attachment 418320 [details]
Attached traceback automatically from anaconda.

Comment 9 Vyhnalek Petr 2010-06-01 12:48:35 UTC
Created attachment 418626 [details]
Attached traceback automatically from anaconda.

Comment 10 kruvalig 2010-06-01 16:59:04 UTC
Created attachment 418732 [details]
Attached traceback automatically from anaconda.

Comment 11 kruvalig 2010-06-01 17:01:29 UTC
Created attachment 418736 [details]
Attached traceback automatically from anaconda.

Comment 12 Arthur 2010-06-05 22:11:05 UTC
Created attachment 421503 [details]
Attached traceback automatically from anaconda.

Comment 13 Arthur 2010-06-08 16:44:13 UTC
Created attachment 422270 [details]
Attached traceback automatically from anaconda.

Comment 14 Ahmet 2010-06-09 16:33:18 UTC
Created attachment 422617 [details]
Attached traceback automatically from anaconda.

Comment 15 machnik.pawel 2010-06-11 20:26:32 UTC
Created attachment 423387 [details]
Attached traceback automatically from anaconda.

Comment 16 Diogo 2010-06-22 01:56:05 UTC
Created attachment 425794 [details]
Attached traceback automatically from anaconda.

Comment 17 Tomasz Ostrowski 2010-06-24 18:45:35 UTC
Created attachment 426680 [details]
Attached traceback automatically from anaconda.

Comment 18 machnik.pawel 2010-06-25 04:41:21 UTC
My solution:
1. comment out the entries about ntfs partiton in /etc/fstab
2. make preupgrade
3. uncomment entires from 1.

For me worked.

Comment 19 Prabhakaran 2010-06-26 17:01:37 UTC
Created attachment 427098 [details]
Attached traceback automatically from anaconda.

Comment 20 Leo Bosnjak 2010-08-18 20:56:35 UTC
Created an attachment (id=439503)
Attached traceback automatically from anaconda.

Comment 21 David Kovalsky 2010-08-25 06:57:03 UTC
Created an attachment (id=440844)
Attached traceback automatically from anaconda.

Comment 22 mrblack 2010-08-25 21:16:41 UTC
Created an attachment (id=441054)
Attached traceback automatically from anaconda.

Comment 23 Chris Schanzle 2010-08-31 13:57:42 UTC
Created an attachment (id=442188)
Attached traceback automatically from anaconda.

Comment 24 megareg 2010-09-07 15:13:04 UTC
Created an attachment (id=443537)
Attached traceback automatically from anaconda.

Comment 25 Morgan McBee 2010-09-17 14:50:31 UTC
Created attachment 448025 [details]
Attached traceback automatically from anaconda.

Comment 26 Morgan McBee 2010-09-17 15:03:08 UTC
Created attachment 915151 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).

Comment 27 Morgan McBee 2010-09-17 15:13:56 UTC
Comment on attachment 448025 [details]
Attached traceback automatically from anaconda.

Please delete.

Comment 28 patchesthecaveman 2010-09-18 05:43:03 UTC
Created attachment 448165 [details]
Attached traceback automatically from anaconda.

Comment 29 zimon 2010-11-05 21:48:47 UTC
Created attachment 458245 [details]
Attached traceback automatically from anaconda.

Comment 30 shakka.by 2010-12-04 13:07:56 UTC
Created attachment 464742 [details]
Attached traceback automatically from anaconda.


Note You need to log in before you can comment on or make changes to this bug.