Bug 59592 - postfix upgrade fails
Summary: postfix upgrade fails
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postfix (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-10 22:24 UTC by Chris Ricker
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-19 19:20:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2002-02-10 22:24:53 UTC
<This is probably more correctly filed against postfix, but there is no entry
for postfix in bugzilla currently>

Upgrading to hampton beta1 from RH 7.x systems which have postfix fails with the
error:

useradd: user postfix exists
execution of %pre scriptlet from postfix-1.1.2-3 failed, exit status 9

install: %pre scriptlet failed (2), skipping postfix-1.1.2-3

this is probably because the RPM does an unconditional add of the user postfix,
rather than first checking for the existance of the postfix account.

Since RH did in the past ship postfix RPMs in powertools, this may pose problems.

Comment 1 Michael Fulbright 2002-02-12 17:51:23 UTC
Postfix bug.

Comment 2 Bernhard Rosenkraenzer 2002-02-21 14:56:38 UTC
 Fixed in 1.1.3-2


Note You need to log in before you can comment on or make changes to this bug.