Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 595949 - Can't yum update.
Can't yum update.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-25 20:51 EDT by Walter Tuvell
Modified: 2014-01-21 18:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-26 00:06:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of failed update transaction. (218.71 KB, image/png)
2010-05-26 08:01 EDT, Walter Tuvell
no flags Details

  None (edit)
Description Walter Tuvell 2010-05-25 20:51:59 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.9) Gecko/20100330 Fedora/3.5.9-2.fc12 Ant.com Toolbar 2.0 Firefox/3.5.9

I tried doing a software update (both via GUI and via yum command), and it failed.

The GUI failure yields a notification box that says Transaction Error,  with the details: "could not add package update for arts-8:1.5.10-12.fc12(i686)updates: 8:arts-1.5.10-12.fc12.i686".

The following is the output I get from a "yum update" (note that doing "yum --skip-broken update" also fails):

Loaded plugins: auto-update-debuginfo, refresh-packagekit
Found 59 installed debuginfo package(s)
Enabling fedora-debuginfo: Fedora 12 - x86_64 - Debug
Reading repository metadata in from local files
Enabling rpmfusion-free-debuginfo: RPM Fusion for Fedora 12 - Free - Debug
Reading repository metadata in from local files
Enabling rpmfusion-nonfree-debuginfo: RPM Fusion for Fedora 12 - Nonfree - Debug
Reading repository metadata in from local files
Enabling rpmfusion-free-updates-debuginfo: RPM Fusion for Fedora 12 - Free - Updates Debug
Reading repository metadata in from local files
Enabling rpmfusion-nonfree-updates-debuginfo: RPM Fusion for Fedora 12 - Nonfree - Updates Debug
Reading repository metadata in from local files
Enabling updates-debuginfo: Fedora 12 - x86_64 - Updates - Debug
Reading repository metadata in from local files
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package GConf2-debuginfo.x86_64 0:2.28.0-4.fc12.2 set to be updated
---> Package enchant-debuginfo.x86_64 1:1.6.0-1.fc12 set to be updated
---> Package glib2-debuginfo.x86_64 0:2.22.5-1.fc12 set to be updated
---> Package glibc-debuginfo.x86_64 0:2.11.1-6 set to be updated
---> Package gnome-desktop-debuginfo.x86_64 0:2.28.2-6.fc12 set to be updated
---> Package gnome-vfs2-debuginfo.x86_64 0:2.24.2-4.fc12 set to be updated
---> Package gstreamer-debuginfo.x86_64 0:0.10.29-1.fc12 set to be updated
---> Package gtk2-debuginfo.x86_64 0:2.18.9-3.fc12 set to be updated
---> Package libxml2-debuginfo.x86_64 0:2.7.6-2.fc12 set to be updated
---> Package mytharchive.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythbrowser.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythgallery.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythgame.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythmovies.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythmusic.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythnews.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythplugins.x86_64 0:0.23-1.fc12 set to be updated
--> Processing Dependency: mythnetvision = 0.23-1.fc12 for package: mythplugins-0.23-1.fc12.x86_64
---> Package mythtv.x86_64 0:0.23-1.fc12 set to be updated
--> Processing Dependency: mythtv-themes = 0.23 for package: mythtv-0.23-1.fc12.x86_64
---> Package mythtv-backend.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythtv-base-themes.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythtv-common.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythtv-docs.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythtv-frontend.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythtv-libs.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythtv-setup.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythvideo.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythweather.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythweb.x86_64 0:0.23-1.fc12 set to be updated
---> Package mythzoneminder.x86_64 0:0.23-1.fc12 set to be updated
---> Package nspr-debuginfo.x86_64 0:4.8.4-2.fc12 set to be updated
---> Package nss-debuginfo.x86_64 0:3.12.6-4.fc12 set to be updated
---> Package nss-softokn-debuginfo.x86_64 0:3.12.4-19.fc12 set to be updated
---> Package nss-util-debuginfo.x86_64 0:3.12.6-1.fc12 set to be updated
---> Package openldap-debuginfo.x86_64 0:2.4.19-4.fc12 set to be updated
---> Package openssl-debuginfo.x86_64 0:1.0.0-4.fc12 set to be updated
---> Package perl-MythTV.x86_64 0:0.23-1.fc12 set to be updated
---> Package python-MythTV.x86_64 0:0.23-1.fc12 set to be updated
---> Package scribus-debuginfo.x86_64 0:1.3.6-2.fc12 set to be updated
--> Running transaction check
---> Package mythnetvision.x86_64 0:0.23-1.fc12 set to be updated
--> Processing Dependency: perl(XML::RSS) for package: mythnetvision-0.23-1.fc12.x86_64
---> Package mythtv.x86_64 0:0.23-1.fc12 set to be updated
--> Processing Dependency: mythtv-themes = 0.23 for package: mythtv-0.23-1.fc12.x86_64
--> Running transaction check
---> Package mythtv.x86_64 0:0.23-1.fc12 set to be updated
--> Processing Dependency: mythtv-themes = 0.23 for package: mythtv-0.23-1.fc12.x86_64
---> Package perl-XML-RSS.noarch 0:1.45-1.fc12 set to be updated
--> Processing Dependency: perl(DateTime::Format::Mail) for package: perl-XML-RSS-1.45-1.fc12.noarch
--> Processing Dependency: perl(DateTime::Format::W3CDTF) for package: perl-XML-RSS-1.45-1.fc12.noarch
--> Running transaction check
---> Package mythtv.x86_64 0:0.23-1.fc12 set to be updated
--> Processing Dependency: mythtv-themes = 0.23 for package: mythtv-0.23-1.fc12.x86_64
---> Package perl-DateTime-Format-Mail.noarch 0:0.3001-5.fc12 set to be updated
--> Processing Dependency: perl(DateTime) >= 0.18 for package: perl-DateTime-Format-Mail-0.3001-5.fc12.noarch
--> Processing Dependency: perl(Params::Validate) for package: perl-DateTime-Format-Mail-0.3001-5.fc12.noarch
---> Package perl-DateTime-Format-W3CDTF.noarch 0:0.04-7.fc12 set to be updated
--> Running transaction check
---> Package mythtv.x86_64 0:0.23-1.fc12 set to be updated
--> Processing Dependency: mythtv-themes = 0.23 for package: mythtv-0.23-1.fc12.x86_64
---> Package perl-DateTime.x86_64 1:0.4501-3.fc12 set to be updated
--> Processing Dependency: perl(Class::Singleton) >= 1.03 for package: 1:perl-DateTime-0.4501-3.fc12.x86_64
--> Processing Dependency: perl(List::MoreUtils) for package: 1:perl-DateTime-0.4501-3.fc12.x86_64
--> Processing Dependency: perl(Class::Singleton) for package: 1:perl-DateTime-0.4501-3.fc12.x86_64
---> Package perl-Params-Validate.x86_64 0:0.95-1.fc12 set to be updated
--> Running transaction check
---> Package mythtv.x86_64 0:0.23-1.fc12 set to be updated
--> Processing Dependency: mythtv-themes = 0.23 for package: mythtv-0.23-1.fc12.x86_64
---> Package perl-Class-Singleton.noarch 0:1.4-5.fc12 set to be updated
---> Package perl-List-MoreUtils.x86_64 0:0.22-9.fc12 set to be updated
--> Finished Dependency Resolution
Error: Package: mythtv-0.23-1.fc12.x86_64 (rpmfusion-free-updates)
           Requires: mythtv-themes = 0.23
           Installed: mythtv-themes-0.22-2.fc12.noarch (@rpmfusion-free-updates)
           Available: mythtv-themes-0.22-1.fc12.noarch (rpmfusion-free)
 You could try using --skip-broken to work around the problem
msttcorefonts-2.0-1.noarch has missing requires of /usr/sbin/chkfontpath


Reproducible: Always

Steps to Reproduce:
1. Try to do "yum update" (or, try to do GUI update).  See Details, above.

Actual Results:  
See Details, above.

Expected Results:  
Updating should succeed.

See Details, above.
Comment 1 James Antill 2010-05-26 00:06:39 EDT
You can just do: --exclude mythtv\* ... until mythtv is fixed in rpmfusion.
Comment 2 Walter Tuvell 2010-05-26 07:59:10 EDT
I'm not so sure this is solely a mythtv/rpmfusion problem.

For, I tried updating again this morning (using GUI update), and again I got a Transaction Error.  This time, the Details said: "No Transaction to process".  See attached screenshot.

While it's true that the updates being attempted are all MythTV updates, a MythTV problem shouldn't corrupt an update transaction, should  it?
Comment 3 Walter Tuvell 2010-05-26 08:01:14 EDT
Created attachment 416778 [details]
Screenshot of failed update transaction.

Screenshot showing the problem I'm seeing.
Comment 4 James Antill 2010-05-26 09:30:38 EDT
That's a PK problem, and I'm not really sure what it means.

If you run yum directly I can tell if it's a yum bug or, more likely, a packaging/repo. problem.

But the problem in the initial report, yum fails dep. resolution, is almost certainly a mythtv pacakge or rpmfusion repo. problem.
Comment 5 Walter Tuvell 2010-05-26 10:08:44 EDT
Upon closer inspection/reporting, it looks like this may be a 3-part bug:

1. Running update from the GUI (Package Kit, GnomePK in my case) first gives the Transaction Error I most recently reported: "No transaction to process".

2. Re-running update from GUI (without shutting down the GPK session) then gives the Transaction Error I reported yesterday: "could not add package update for
arts-8:1.5.10-12.fc12(i686)updates: 8:arts-1.5.10-12.fc12.i686".

3. Running "yum update" directly gives the yum error I reported yesterday.

It seems you have resolved #3 ("if it hurts to update MythTV, don't do that" :-).  Fair enough.

But for #1 and #2, it seems somebody in PK-land might want to have a look.  Would it make sense to re-route this bug report to the PK software maintainers?

And, how about informing the mythtv/rpmfusion/repo maintainers themselves?

Note You need to log in before you can comment on or make changes to this bug.