Bug 595984 - Remove unsupported remote api's
Summary: Remove unsupported remote api's
Status: CLOSED NOTABUG
Alias: None
Product: RHQ Project
Classification: Other
Component: Core Server   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
urgent
medium vote
Target Milestone: ---
: ---
Assignee: Jay Shaughnessy
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: jon-sprint11-bugs
TreeView+ depends on / blocked
 
Reported: 2010-05-26 04:04 UTC by Charles Crouch
Modified: 2015-02-01 23:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 21:47:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Charles Crouch 2010-05-26 04:04:30 UTC
From looking at http://rhq-project.org/display/RHQ/API+Changes+Between+JOPR+2.3.1+And+RHQ+3.0.0

There seem to be a number of candidates for removal:
    * AdvisoryManagerRemote
    * EntitlementStuffManagerRemote
    * PerspectiveManagerRemote
    * SavedSearchManager

Because these features are unused in the JON2.4 release or will go through substantial change in the next release.

Comment 1 Jay Shaughnessy 2010-07-07 21:40:13 UTC
These and more were removed. 

SavedSearchManager was maintained after a discussion where it was decided the API is in decent shape.  Not all saved search options may be initially supported but the API is good.

Comment 2 Jay Shaughnessy 2010-07-07 21:47:22 UTC
Note, much of this work was performed earlier, here: https://bugzilla.redhat.com/show_bug.cgi?id=580254


Note You need to log in before you can comment on or make changes to this bug.