This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 596029 - Bind doesn't copy over named.conf to chroot; upgrading to F13 broke bind
Bind doesn't copy over named.conf to chroot; upgrading to F13 broke bind
Status: CLOSED DUPLICATE of bug 595025
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 03:18 EDT by D. Wagner
Modified: 2013-04-30 19:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-01 08:26:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description D. Wagner 2010-05-26 03:18:35 EDT
Description of problem:

I upgraded from F12 to F13 today, and afterwards, bind stopped working.  I use a chrooted version of bind.  My best guess at the cause of the problem is that the update to bind updated /etc/named.conf, but these updates were not copied over to /var/named/chroot/etc/named.conf.

Now I cannot start named; I get the following error:
# service named restart
Stopping named:                                            [  OK  ]
Starting named: 
Error in named configuration:
/etc/named.conf:77: open: /etc/pki/dnssec-keys/dlv/dlv.isc.org.conf: file not found
                                                           [FAILED]
There is no line 77 in /etc/named.conf; on the other hand, line 77 of /var/named/chroot/etc/named.conf is
  include "/etc/pki/dnssec-keys/dlv/dlv.isc.org.conf";
and there is no such file on my filesystem.  /etc/named.conf does not contain that problematic include line.  I cannot run system-config-bind; it errors out with a similar error message.

Should there be some script that copies the latest version of all of the relevant files into the chroot environment (/var/named/chroot)?

Other information: As part of the upgrade, I did have to move /etc/named.conf.rpmnew to /etc/named.conf.


Version-Release number of selected component (if applicable):

bind-9.7.0-9.P1.fc13.x86_64
bind-chroot-9.7.0-9.P1.fc13.x86_64
Comment 1 D. Wagner 2010-05-26 04:09:28 EDT
"yum reinstall bind-chroot" does not fix this problem.  "yum reinstall bind" does not fix it, either.
Comment 2 Adam Tkac 2010-06-01 08:26:19 EDT
This is same issue as bug #595025. Can you reply to https://bugzilla.redhat.com/show_bug.cgi?id=595025#c1, please? Thank you.

*** This bug has been marked as a duplicate of bug 595025 ***

Note You need to log in before you can comment on or make changes to this bug.