Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 596040 - F12->F13 update fails to install grub and leaves system unbootable
F12->F13 update fails to install grub and leaves system unbootable
Status: CLOSED DUPLICATE of bug 509622
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 04:04 EDT by D. Wagner
Modified: 2010-05-26 12:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-26 11:05:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (10.25 KB, text/plain)
2010-05-26 12:30 EDT, D. Wagner
no flags Details

  None (edit)
Description D. Wagner 2010-05-26 04:04:50 EDT
Description of problem:

I upgraded from Fedora 12 to Fedora 13 tonight using the F13 DVD (Anaconda upgrader, not preupgrade).  Previously, the system booted fine.  After the upgrade, the system would no longer boot.  Instead, on booting, I got a grub prompt (I think it was "grub> ", but I'm not certain) and the system didn't boot into linux.  There were no errors in /root/update.log or /root/update.log.syslog.

To fix this, I had to mount the rescue disk and run "chroot /mnt/sysimage" and "grub-install /dev/sdb".

In case it is relevant, I have two hard disks, /dev/sda and /dev/sdb.  My Linux installation is on /dev/sdb, and that's the one that I upgraded with Anaconda.  I have /boot on a separate partition from /.

This is a long-standing problem in Anaconda and apparently remains unfixed.  It has been reported against F9, F10, F11, F12, and now F13.  From a user experience perspective, this is not good: most users cannot be expected to diagnose or recover from this error condition, and it leads to an unusable and unbootable system.  See, e.g., bug #450143, bug #509622, and the following mailing list message:
  http://lists.fedoraproject.org/pipermail/users/2010-May/373041.html
Comment 1 Chris Lumens 2010-05-26 08:56:49 EDT
Please attach /var/log/anaconda*log to this bug report.
Comment 2 Chris Lumens 2010-05-26 11:05:32 EDT
Marking as a dup of another bug.  If you could, please attach the requested information to that one instead.  Thanks.

*** This bug has been marked as a duplicate of bug 509622 ***
Comment 3 D. Wagner 2010-05-26 12:30:10 EDT
Created attachment 416919 [details]
anaconda.log

Note You need to log in before you can comment on or make changes to this bug.