Bug 59605 - versioning problems with "Wireless Extension"
Summary: versioning problems with "Wireless Extension"
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: wireless-tools   
(Show other bugs)
Version: 1.0
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-11 02:44 UTC by Peter E. Popovich
Modified: 2014-03-17 02:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 17:46:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter E. Popovich 2002-02-11 02:44:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
kernel-2.4.17-0.13 (current rawhide)
kernel-pcmcia-cs-3.1.27-12 (current rawhide)
wireless-tools-21-4 (current rawhide)

It appears that wireless drivers were built for Wireless Extension version 12, 
but the wireless-tools package is still version 11, which causes iwconfig to 
squawk.

(Using an Addtron AWP-100 and orinoco_cs)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run iwconfig.

Actual Results:  #ika:i686# iwconfig eth0
Warning : Device eth0 has been compiled with version 12
of Wireless Extension, while we are using version 11.
Some things may be broken...

eth0      IEEE 802.11-DS  ESSID:"default"  Nickname:"ika"
[rest of iwconfig output appears nomal]

Expected Results:  Conditions causing warning should not exist.


Additional info:

Based on a cursory scan of 
http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html, it looks like 
the kernel is up to date, and it's probably just a simple matter of rebuilding 
the wireless-tools package for the kernel's version of Wireless Extension.

Comment 1 Bill Nottingham 2002-03-28 09:05:30 UTC
fixed in 23-2.


Note You need to log in before you can comment on or make changes to this bug.