Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 596071 - Failed conversion leaves orphaned images on RHEV export domain
Failed conversion leaves orphaned images on RHEV export domain
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
: 601026 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 05:23 EDT by Matthew Booth
Modified: 2010-11-09 08:22 EST (History)
8 users (show)

See Also:
Fixed In Version: virt-v2v-0.6.1-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 15:47:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0566 normal SHIPPED_LIVE virt-v2v bug fix update 2010-07-27 15:47:38 EDT

  None (edit)
Description Matthew Booth 2010-05-26 05:23:11 EDT
Description of problem:
If a conversion fails, the transferred images are not cleaned up. While this is a feature when converting to a libvirt target, RHEV does not provide an interface to manage these images. The only way to remove them is manually.

Version-Release number of selected component (if applicable):
virt-v2v-0.6.0-1.el5
Comment 1 Matthew Booth 2010-06-07 04:58:42 EDT
*** Bug 601026 has been marked as a duplicate of this bug. ***
Comment 2 Matthew Booth 2010-06-08 11:41:14 EDT
A conversion can fail for many reasons. The most likely are that the user killed the conversion with Ctrl-C, or the conversion was unable to complete for some reason.

There are 2 good tests for this. In both cases, start with an empty export storage domain: the images/ and master/vms/ should be empty.

1. Start a conversion. Before it completes, kill it with a Ctrl-C to the terminal running the conversion.
2. Attempt to convert a Xen PV guest which isn't registered to RHN on a host with no files in /var/lib/virt-v2v/software. This will fail because there is no FV kernel available.

In both cases, the export storage domain should still be empty after the test.
Comment 3 Matthew Booth 2010-06-08 12:48:08 EDT
Fix posted: https://www.redhat.com/archives/libguestfs/2010-June/msg00064.html
Comment 4 Matthew Booth 2010-06-08 13:34:33 EDT
Fixed in 0.6.0-4.el5
Comment 5 Mohua Li 2010-06-09 23:04:58 EDT
pls see Bug 596015, commnets 7,9, it fail at virt-v2v-0.6.0-6, as tmp directory not clear by the fail at above 2 comments
Comment 7 Mohua Li 2010-07-16 05:35:30 EDT
test on 

libguestfs-1.2.7-1.el5.6
virt-v2v-0.6.1-1.el5



1), quit the convert when transferring the image, umount successfully,no orphaned image left,pass
2), quit the convert during conversion, umount successfully,no orphaned image left,pass
3), check the mount after convert finished successfully,umount successfully, no orphaned image left,pass

so set the status to verified,
Comment 9 errata-xmlrpc 2010-07-27 15:47:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0566.html

Note You need to log in before you can comment on or make changes to this bug.