Bug 59609 - Hangs when selecting preferences - updating from Metadata Server
Summary: Hangs when selecting preferences - updating from Metadata Server
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnorpm   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-11 04:35 UTC by John J. Germs
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-12 17:39:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John J. Germs 2002-02-11 04:35:50 UTC
Description of Problem:


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. Select Operations tab
2. Select Preferences
3. Have a bad connection to the internet or the Metadata Server is down / too busy. 

Actual Results:


Expected Results:


Additional Information:
In My opinion gnorpm should not automatically update from the metadata server
(ie: http://www.redhat.com/RDF ). It should pop up with a window saying that
there may be an updated list available, would you like to check and update your
list? .... Or something of that nature.
If you have a bad connection to the internet or the Metaserver is down for some
reason the application will just hang.....
Also I have experienced this on other PC's that have a network card in them but
strictly hook up to the internet via a modem. In these instances gnorpm will
assume it can download because of there being an internal address even though
there is no internet connection present.
Just yesterday I was showing a friend gnorpm and the extra setting you can use
when this happened.... This didn't make things look good.... hehe.

Comment 1 Havoc Pennington 2002-02-26 20:50:15 UTC
Only critical bugfixes are going in to gnorpm at this stage, deferring this issue.


Note You need to log in before you can comment on or make changes to this bug.