Bug 596107 - Satellite WeUI shows 0 errara count for some systems even if there are packages available for update. This results in Packages without Errata links the SDC
Satellite WeUI shows 0 errara count for some systems even if there are packag...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2010-05-26 06:29 EDT by Vishal Gaikwad
Modified: 2016-02-04 10:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 10:14:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vishal Gaikwad 2010-05-26 06:29:30 EDT
Description of problem:
RHN Satellite 530 server is not properly displaying errata on the Systems tab.  If we look at the "System Overview" page, we see numbers in the packages column, but 0's in the errata column.  If we go to the Errata tab, under the Relevant section there are no errata.

Version-Release number of selected component (if applicable):
RHNS 530

How Reproducible
- Not Always.

Steps to Reproduce
- sync a RHEL5 base and child channel and register a system
- After a couple of days when new errata are released, Go to Systems Overview page and check the errata and packages count.

Observed Behavior
- For some systems it shows 0 errata count and 10-12 packages with no errata links

Expected Behavior
- Package should have errata links
Comment 1 Vishal Gaikwad 2010-05-26 06:30:24 EDT
A workaround is to use : satellite-sync --force-errata -c <<channel_name>>
Comment 5 Justin Sherrill 2010-08-26 17:48:03 EDT
I'm not able to reproduce this myself, nor on any of our 5.3 systems that have been running for quite a while.

Can you point me to a reproducer?

Also, I'm a tad confused.  The yum cache (located within /var/cache/rhn/repodata) is completely different to the errata/package cache (located in the rhnServerNeededcache table).  

-Justin
Comment 10 Tomas Lestach 2016-02-04 10:14:57 EST
We have re-reviewed this bug, as part of an ongoing effort to improve  Satellite/Proxy feature and bug updates, review and backlog.

We believe this bug has been fixed in the latest Satellite 5 version (5.7), so closing the bug as CURRENTRELEASE. Please feel free to re-open in case you discover any issues.

Tomas and Xixi

Note You need to log in before you can comment on or make changes to this bug.