Bug 59619 - encodings.dir files disappear after upgrade to XFree86-4.2.0-6.30?
encodings.dir files disappear after upgrade to XFree86-4.2.0-6.30?
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-02-11 07:54 EST by Jonathan Kamens
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 04:03:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-02-11 07:54:59 EST
jik:~!73> rpm --verify XFree86-base-fonts
missing    /usr/X11R6/lib/X11/fonts/Speedo/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/Type1/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/misc/encodings.dir

What's up with that?
Comment 1 Mike A. Harris 2002-02-11 08:01:18 EST
Not sure, but I'll look into it.  One thing to note, is that XFree86
no longer requires these files to be present, and XFree86.org has
deprecated them.  If I understand correctly, 4.3.0 when released will
have made the deprecation official, and by default the files will not
be produced, and 4.4.0 will not support it any longer.

I think what the problem is here, is missing %verify flags on that
subpackage for those files.  They also should be %ghost IMHO.

Comment 2 Mike A. Harris 2002-03-28 08:05:22 EST
I have now added entries in the spec file to flag these files as ghosts,
so their existance will be owned, and they will bypass verification as
they are transient.

Again, note that encodings.dir files are deprecated by XFree86.org, and
are currently completely unnecessary.  XFree86 4.3.0 will not generate
or use encodings.dir any longer aparently, so these files will not be
supported in future releases.

The new flagged files are in build 4.2.0-6.51 and later in rawhide.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.