Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 596238 - Unhelpful error message when converting Windows guest with missing deps
Unhelpful error message when converting Windows guest with missing deps
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 08:40 EDT by Matthew Booth
Modified: 2010-06-22 08:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.6.0-3.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-22 08:49:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2010:0495 normal SHIPPED_LIVE new package: virt-v2v 2010-06-22 08:48:39 EDT

  None (edit)
Description Matthew Booth 2010-05-26 08:40:50 EDT
Description of problem:
When converting a Windows guest, if dependencies specified in the config file are not found the code dies untidily:

[root@t500 virt-v2v]# ./v2v/run-v2v-locally -f v2v/virt-v2v.conf -ic qemu+ssh://root@blue.rhev.marston/system -o rhev -osd blue:/export/export winxp-minimal
root@blue.rhev.marston's password: 
root@blue.rhev.marston's password: 
cp: cp: cannot stat `/sysroot/transferECnJPK/windows/xp/i386/viostor.sys': No such file or directory at /home/mbooth/src/virt-v2v/blib/lib/Sys/VirtV2V/Converter/Windows.pm line 359.

It should do the same as the Linux converter, which is to attempt to determine all missing dependencies at once and report them in a single error message.

Version-Release number of selected component (if applicable):
virt-v2v-0.6.0-1.el5
Comment 1 Matthew Booth 2010-05-28 06:46:21 EDT
Fix posted:

https://www.redhat.com/archives/libguestfs/2010-May/msg00152.html
Comment 2 Matthew Booth 2010-06-07 08:39:57 EDT
Fixed in 0.6.0-3.el5
Comment 3 Rita Wu 2010-06-08 06:45:10 EDT
Verified on virt-v2v-0.6.0-3.el5 + v2v-libvirt-0.8.1-1.el5

Now it will point the installation failed reason in a single error msg when missing deps.

=========For Linux Guest================
# virt-v2v -f /etc/virt-v2v.conf -i libvirtxml -o rhev -osd 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/fcp_export /tmp/xen-rhel54-64-pv-raw.img.xml
virt-v2v: Installation failed because the following files referenced in the configuration file are required, but missing: rhel/5/kernel-2.6.18-128.el5.x86_64.rpm rhel/5/ecryptfs-utils-56-8.el5.x86_64.rpm rhel/5/ecryptfs-utils-56-8.el5.i386.rpm
virt-v2v: Installation failed because the following files referenced in the configuration file are required, but missing: rhel/5/kernel-2.6.18-128.el5.x86_64.rpm rhel/5/ecryptfs-utils-56-8.el5.x86_64.rpm rhel/5/ecryptfs-utils-56-8.el5.i386.rpm
virt-v2v: No bootable kernels installed, and no replacement is available.
Unable to continue.
virt-v2v: Failed to unmount 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/fcp_export. Command exited with status 1. Output was: umount: /tmp/uZcjLgbaYc: device is busy
umount: /tmp/uZcjLgbaYc: device is busy

virt-v2v: Failed to remove mount directory /tmp/uZcjLgbaYc: Device or resource busy


========For Windows Guest=============
#virt-v2v -i libvirtxml -o rhev -osd 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/fcp_export /tmp/win2008-32.raw.xml
virt-v2v: Installation failed because the following files referenced in the configuration file are required, but missing: windows/2008/i386/viostor.sys windows/firstboot.bat windows/rhev-apt.exe windows/rhsrvany.exe
virt-v2v: Failed to unmount 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/fcp_export. Command exited with status 1. Output was: umount: /tmp/p7Xxg0ofKn: device is busy
umount: /tmp/p7Xxg0ofKn: device is busy
Comment 6 errata-xmlrpc 2010-06-22 08:49:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2010-0495.html

Note You need to log in before you can comment on or make changes to this bug.