Bug 596250 - libguestfs cannot be installed
Summary: libguestfs cannot be installed
Status: CLOSED DUPLICATE of bug 595920
Alias: None
Product: Fedora
Classification: Fedora
Component: libguestfs   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 13:09 UTC by Peter van Hooft
Modified: 2010-05-26 14:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-26 14:48:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter van Hooft 2010-05-26 13:09:30 UTC
Description of problem:
libguestfs requires /usr/lib64/libcrypto.so.10, but since openssl-1.0.0-4.fc13.x86_64 installs this in /lib64.

Version-Release number of selected component (if applicable):
1.2.4-1.fc13.x86_64

How reproducible:
yum install libguestfs

Steps to Reproduce:
1.
2.
3.
  
Actual results:
# yum install libguestfs
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package libguestfs.x86_64 1:1.2.4-1.fc13 set to be updated
--> Processing Dependency: /usr/lib64/.libcrypto.so.10.hmac for package: 1:libguestfs-1.2.4-1.fc13.x86_64
--> Processing Dependency: /usr/lib64/.libcrypto.so.1.0.0.hmac for package: 1:libguestfs-1.2.4-1.fc13.x86_64
--> Processing Dependency: /usr/lib64/libcrypto.so.10 for package: 1:libguestfs-1.2.4-1.fc13.x86_64
--> Processing Dependency: /usr/lib64/libcrypto.so.10 for package: 1:libguestfs-1.2.4-1.fc13.x86_64
--> Processing Dependency: /usr/lib64/.libcrypto.so.1.0.0.hmac for package: 1:libguestfs-1.2.4-1.fc13.x86_64
--> Processing Dependency: /usr/lib64/.libcrypto.so.10.hmac for package: 1:libguestfs-1.2.4-1.fc13.x86_64
--> Finished Dependency Resolution
Error: Package: 1:libguestfs-1.2.4-1.fc13.x86_64 (updates)
           Requires: /usr/lib64/libcrypto.so.10
           Available: openssl-1.0.0-1.fc13.x86_64 (fedora)
Error: Package: 1:libguestfs-1.2.4-1.fc13.x86_64 (updates)
           Requires: /usr/lib64/.libcrypto.so.1.0.0.hmac
           Available: openssl-1.0.0-1.fc13.x86_64 (fedora)
Error: Package: 1:libguestfs-1.2.4-1.fc13.x86_64 (updates)
           Requires: /usr/lib64/.libcrypto.so.10.hmac
           Available: openssl-1.0.0-1.fc13.x86_64 (fedora)
 You could try using --skip-broken to work around the problem


Expected results:
libguestfs instaled

Additional info:

Comment 1 Richard W.M. Jones 2010-05-26 14:48:34 UTC
Please try the version in updates-testing.

*** This bug has been marked as a duplicate of bug 595920 ***


Note You need to log in before you can comment on or make changes to this bug.