Bug 596258 - Missing test.support module
Summary: Missing test.support module
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python3 (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 13:31 UTC by Robert de Vries
Modified: 2010-10-12 03:11 UTC (History)
3 users (show)

Fixed In Version: python3-3.1.2-14.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-12 03:11:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Provided patch to add the missing file to the python3 RPM (296 bytes, patch)
2010-05-26 13:31 UTC, Robert de Vries
no flags Details | Diff

Description Robert de Vries 2010-05-26 13:31:25 UTC
Created attachment 416833 [details]
Provided patch to add the missing file to the python3 RPM

Description of problem:


Version-Release number of selected component (if applicable):
python3-3.1.2-4.fc13.i686

How reproducible:
Always

Steps to Reproduce:
1. python3
2. >>> import test.support
  
Actual results:
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named support
>>>

Expected results:
>>>

Additional info:
Patch provided for RPM spec file

Comment 1 Dave Malcolm 2010-05-26 13:53:43 UTC
Thanks for filing this bug report and the patch.

It looks like test/support.py is packaged within the python3-test subpackage, rather than within the python3 core package.

Am I right in guessing that you're using test.support for a 3rd-party test suite (i.e. external to python3 itself)?

Comment 2 Robert de Vries 2010-05-26 17:29:06 UTC
Correct, I have submitted an rpm for python3-iniparse and I found that python3 lacked this specific module.
The same module (called test_support.py in python2 was packaged together with the python(2) package, so I assumed that this package belongs to the python3 core package rather than with the python3-test package.

Comment 3 Robert de Vries 2010-05-31 21:26:48 UTC
Another reason for including this file into the core python3 package is that this module is part of the python standard library.

Ref:
http://docs.python.org/py3k/library/test.html#module-test.support

Comment 4 Robert de Vries 2010-09-08 08:11:39 UTC
I just noted that in the new python3 package this fix is not present.
ref: python3-3.1.2-7.fc13.i686

Comment 5 Dave Malcolm 2010-09-08 22:52:31 UTC
Building python3-3.1.2-8.fc13 for dist-f13-updates-candidate
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=2456525

Comment 6 Dave Malcolm 2010-09-08 22:55:34 UTC
Building python3-3.1.2-14.fc14 for dist-f14-updates-candidate
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=2456530

Comment 7 Dave Malcolm 2010-09-08 23:04:24 UTC
Building python3-3.2-0.3.a1.fc15 for dist-rawhide
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=2456541

Comment 8 Fedora Update System 2010-09-08 23:08:19 UTC
python3-3.1.2-8.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/python3-3.1.2-8.fc13

Comment 9 Fedora Update System 2010-09-08 23:22:50 UTC
python3-3.1.2-14.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python3-3.1.2-14.fc14

Comment 10 Fedora Update System 2010-09-09 04:10:47 UTC
python3-3.1.2-14.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python3'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/python3-3.1.2-14.fc14

Comment 11 Fedora Update System 2010-10-12 03:11:48 UTC
python3-3.1.2-14.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.