Bug 59626 - RFE: Build without gnome-libs
Summary: RFE: Build without gnome-libs
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xchat (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-11 14:10 UTC by Bernhard Rosenkraenzer
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-06 19:32:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for spec file (1.27 KB, patch)
2002-02-11 14:10 UTC, Bernhard Rosenkraenzer
no flags Details | Diff

Description Bernhard Rosenkraenzer 2002-02-11 14:10:17 UTC
Description of Problem:
Buidling xchat without linking in 100 gnome libs doesn't reduce its
functionality, but makes it much less bloated. (Try the non-gnome version for
yourself, you won't notice a difference).

Version-Release number of selected component (if applicable):
1.8.7-5

How Reproducible:
100%

Steps to Reproduce:
1. rpm -e gnome-libs
2. rpm -i xchat-1.8.7-5.i386.rpm

Comment 1 Bernhard Rosenkraenzer 2002-02-11 14:10:46 UTC
Created attachment 45219 [details]
Patch for spec file

Comment 2 Mike A. Harris 2002-02-11 14:18:57 UTC
Ok, I'll build it without GNOME support some time and see what all is
different.  If it is unnoticeable, possibly I'll toss it in rawhide.

Comment 3 Mike A. Harris 2002-03-26 21:57:24 UTC
xchat 1.8.8-3 in rawhide is now built with GNOME support disabled.
It appears that there should not be any major loss of functionality.
GNOME support was for sound and GNOME panel support only, and a crash
dialog also.  None of which I consider mission critical.  I'll leave it
disabled unless there becomes some compelling reason to re-enable it.



Comment 4 Jeremy Katz 2002-04-06 19:32:37 UTC
And keybindings, and pixmaps on buttons and several other things that I've seen
people complain about not being present in the past 24 hours now that Skipjack 2
has gone out.

Comment 5 Mike A. Harris 2002-04-08 21:20:47 UTC
Due to many comments, requests, flames received in email, IRC, and in
bugzilla, I've re-enabled GNOME support in xchat.  GNOME support provides
the pixmap'd buttons, as well as the pulldown menus at the top, key
bindings and various other features users have requested be re-enabled.

Bug 62849 is related.


Comment 6 Mike A. Harris 2002-04-10 00:18:46 UTC
Just for documentation - also reported in bug 63043


Note You need to log in before you can comment on or make changes to this bug.