Bug 596282 - XML schema compilation failure with restrict/union
Summary: XML schema compilation failure with restrict/union
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libxml2   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Daniel Veillard
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Keywords:
Depends On: 596277
Blocks: 840699
TreeView+ depends on / blocked
 
Reported: 2010-05-26 14:12 UTC by Lukas Kuklinek
Modified: 2017-12-06 11:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 596277
Environment:
Last Closed: 2017-12-06 11:15:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lukas Kuklinek 2010-05-26 14:12:56 UTC
+++ This bug was initially created as a clone of Bug #596277 +++

Description of problem:
The xmllint tool (or equivalent library call) refuses a valid XML schema.
The schema contains an abstract complex type with simple content that is
derived by another type, which introduces an restriction on its content.

Version-Release number of selected component (if applicable):
2.7.6 and 2.7.7 at least
  
Actual results: schema fails to compile.
Expected results: schema compiles fine.

Additional info:
upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=619640
original message: http://mail.gnome.org/archives/xml/2010-April/msg00011.html

Comment 2 RHEL Product and Program Management 2010-06-07 15:59:06 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Daniel Veillard 2010-07-06 08:12:05 UTC
So there have been no progress upstream, basically I didn't dig the XSD
reference to try to understand what was right or wrong so I think it's too
late for 6.0 GA at this point in any case, retargetting to 6.1

Daniel

Comment 5 RHEL Product and Program Management 2011-01-07 15:37:47 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 8 Jan Kurik 2017-12-06 11:15:52 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.