Bug 596293 - Fatal: Can't find unit Interfaces (Lazarus not build with the same fpc version)
Fatal: Can't find unit Interfaces (Lazarus not build with the same fpc version)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lazarus (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Joost van der Sluis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 10:37 EDT by Nikolay Nikolov
Modified: 2010-10-09 15:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-28 07:51:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikolay Nikolov 2010-05-26 10:37:24 EDT
Description of problem:
Lazarus cannot build programs that use any of the LCL units, because the lazarus F13 package is compiled with an older version of fpc - 2.2.4, and the current fpc version in F13 is 2.4.0

Version-Release number of selected component (if applicable):

Tested on Fedora 13 on x86_64.
fpc-2.4.0-1.fc13.x86_64
lazarus-0.9.28-1.fc13.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. On Fedora 13, install the latest stable fpc and lazarus:
yum install fpc lazarus
2. Run lazarus. An empty windowed application with a form is created.
3. Select Run->Run.
  
Actual results:
Build fails with an error: "project1.lpr(8,7) Fatal: Can't find unit Interfaces used by Project1"

Expected results:
No build errors.
Comment 1 Fedora Update System 2010-05-27 11:14:58 EDT
lazarus-0.9.28.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lazarus-0.9.28.2-1.fc13
Comment 2 Nikolay Nikolov 2010-05-28 06:01:22 EDT
lazarus-0.9.28.2-1.fc13 works for me, thanks!
Comment 3 Joost van der Sluis 2010-05-28 07:51:36 EDT
I just forgot to commit it.
Comment 4 Robert V. Miciovici 2010-10-09 15:38:16 EDT
It seems that lazarus-0.9.28.2-1.fc13 still didn't make it into the repos as of today October 9th 2010

Name        : fpc
Arch        : x86_64
Version     : 2.4.0
Release     : 1.fc13

Name        : lazarus
Arch        : x86_64
Version     : 0.9.28
Release     : 1.fc13

Thank you

Note You need to log in before you can comment on or make changes to this bug.