Bug 596332 - plymouth log viewer should show console output in a monospace font
Summary: plymouth log viewer should show console output in a monospace font
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: plymouth   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 15:49 UTC by jmccann
Modified: 2015-01-14 23:25 UTC (History)
3 users (show)

Fixed In Version: plymouth-0.8.3-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 21:20:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (302.17 KB, image/png)
2010-05-26 15:49 UTC, jmccann
no flags Details
plymouth log viewer - boot messages (74.55 KB, image/png)
2010-07-23 08:36 UTC, Jiri Koten
no flags Details
text mode console output (11.66 KB, image/png)
2010-07-23 08:41 UTC, Jiri Koten
no flags Details

Description jmccann 2010-05-26 15:49:23 UTC
Created attachment 416892 [details]
screenshot

Description of problem:
The log viewer tool seems to have a mismatch between message and result fields

Version-Release number of selected component (if applicable):
plymouth 0.8.3-3

Comment 2 Bill Nottingham 2010-05-26 21:06:32 UTC
... given that it's screenscraping a text mode console, should it use the monospace font? (ick, i know.)

Comment 3 RHEL Product and Program Management 2010-06-07 16:01:16 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Ray Strode [halfline] 2010-06-30 13:11:51 UTC
devack

Comment 5 Ray Strode [halfline] 2010-06-30 13:14:55 UTC
cgit.freedesktop.org/plymouth/commit/?id=6e09dd50ea569a881ebb1fe761849dcc4f12f9f0

Comment 7 Jiri Koten 2010-07-23 08:36:48 UTC
Created attachment 433898 [details]
plymouth log viewer - boot messages

It doesn't seem to be fixed. It looks like there are some extra result fields which don't have any corresponding message.

plymouth-0.8.3-11.el6.x86_64
plymouth-utils-0.8.3-11.el6.x86_64

Comment 8 Jiri Koten 2010-07-23 08:41:37 UTC
Created attachment 433899 [details]
text mode console output

Comment 9 Ray Strode [halfline] 2010-07-23 14:51:44 UTC
Hi,

This bug got changed into "plymouth log viewer should be in a monospace font"

Jon McCann filed 3 separate bugs for the other output issues (against their relevant components).

I've updated the bug summary now to make that clearer.

Comment 10 Jiri Koten 2010-07-26 13:35:33 UTC
Verified in plymouth-0.8.3-11.el6. Monospace font is used.

Comment 11 releng-rhel@redhat.com 2010-11-10 21:20:49 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.