Bug 596339 - [abrt] crash in gpodder-2.5-1.fc13: channel.py:37:new:TypeError: Gtk.Label.set_text() argument 1 must be string, not None
Summary: [abrt] crash in gpodder-2.5-1.fc13: channel.py:37:new:TypeError: Gtk.Label.se...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gpodder
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9012644d
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 15:53 UTC by Daniel Scott
Modified: 2010-06-14 17:10 UTC (History)
2 users (show)

Fixed In Version: gpodder-2.6-7.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-14 17:10:19 UTC


Attachments (Terms of Use)
File: backtrace (879 bytes, text/plain)
2010-05-26 15:53 UTC, Daniel Scott
no flags Details

Description Daniel Scott 2010-05-26 15:53:58 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/gpodder
component: gpodder
executable: /usr/bin/gpodder
kernel: 2.6.33.4-95.fc13.x86_64
package: gpodder-2.5-1.fc13
reason: channel.py:37:new:TypeError: Gtk.Label.set_text() argument 1 must be string, not None
release: Fedora release 13 (Goddard)

backtrace
-----
channel.py:37:new:TypeError: Gtk.Label.set_text() argument 1 must be string, not None

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gpodder/gui.py", line 3138, in on_itemEditChannel_activate
    cover_downloader=self.cover_downloader)
  File "/usr/lib/python2.6/site-packages/gpodder/gtkui/interface/common.py", line 57, in __init__
    GtkBuilderWidget.__init__(self, gpodder.ui_folders, gpodder.textdomain, **kwargs)
  File "/usr/lib/python2.6/site-packages/gpodder/gtkui/base.py", line 70, in __init__
    self.new()
  File "/usr/lib/python2.6/site-packages/gpodder/gtkui/desktop/channel.py", line 37, in new
    self.LabelDownloadTo.set_text( self.channel.save_dir)
TypeError: Gtk.Label.set_text() argument 1 must be string, not None

Local variables in innermost frame:
self: <gpodder.gtkui.desktop.channel.gPodderChannel object at 0x1c47e90>

How to reproduce
-----
1. Click on 'Subscriptions>Podcast Settings'
2.
3.

Comment 1 Daniel Scott 2010-05-26 15:53:59 UTC
Created attachment 416901 [details]
File: backtrace

Comment 2 Jef Spaleta 2010-05-26 18:06:12 UTC
gpodder 2.6 is in updates-testing right now.  Please check to see if this update fixes your problem.


-jef

Comment 3 Jef Spaleta 2010-05-26 18:09:47 UTC
One question... when you chose podcast settings... which podcast in the list was selected? Was it All episodes?

-jef

Comment 4 Daniel Scott 2010-05-26 18:30:06 UTC
The first podcast was *highlighted*. But, I had just started the program, and had not actually selected on any podcast.

Comment 5 Ville-Pekka Vainio 2010-05-26 18:42:55 UTC
I can reproduce this with the 2.6 package in updates-testing if I do Subscriptions -> Podcast settings when the All episode item is selected.

Comment 6 Jef Spaleta 2010-05-26 18:45:46 UTC
(In reply to comment #5)

I have a patch inbound. I'll have koji builds in the next couple of hours.

-jef

Comment 7 Jef Spaleta 2010-05-26 18:57:57 UTC
Okay... scratch build is here.
http://koji.fedoraproject.org/koji/taskinfo?taskID=2211356

I want at least one other person telling me the patched rpm works for them before i push this to bodhi.

You should see a notification bubble telling you to choose another podcast to edit.

-jef

Comment 8 Daniel Scott 2010-05-26 19:06:46 UTC
Fixed for me!

Nice. Thanks.

Comment 9 Fedora Update System 2010-05-26 19:30:45 UTC
gpodder-2.6-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gpodder-2.6-2.fc13

Comment 10 Jef Spaleta 2010-05-26 19:32:12 UTC
(In reply to comment #8)
Okay Dan,

do me a favor and give the update some +1 karma love at the url above.

-jef

Comment 11 Ville-Pekka Vainio 2010-05-26 19:47:57 UTC
Jeff: There might be something not quite right with your fix. I usually run my system with the fi_FI.utf8 locale. With that locale I still get the error. If I run gpodder with the basic C locale, (like "LANG=C gpodder"), your fix seems to work.

Comment 12 Daniel Scott 2010-05-26 19:48:47 UTC
I added a comment with 'Works for me' - It didn't update the Karma.... do I
need a login for the Fedora Updates system?

Comment 13 Jef Spaleta 2010-05-26 20:14:06 UTC
(In reply to comment #11)
Well that's fascinating. Blasted it.  Its because the title string is localized.


Okay homework for you. What channel object property can I rely on that will tell me that its not a real subscription?  active_channel.title  isn't going to cut it.

-jef

Comment 14 Jef Spaleta 2010-05-26 20:30:01 UTC
(In reply to comment #11)


Okay I'm thinking self.active_channel.last_modified will be a winner.

You can test this on your system Ville with the patched version installed by editting

/usr/lib/python2.6/site-packages/gpodder/gui.py

In on_itemEditChannel_activate(self, widget, *args)
change : 
if self.active_channel.title == "All episodes" :

to: 
if self.active_channel.last_modified is None :

And is if the patched version now works.
It looks like the All episodes psuedo subscription only has a few of the channel variables created. Only real subscriptions will have last modified set I think.


Let me know if that change works and I'll respin the patch and the bodhi update.

-jef

Comment 15 Ville-Pekka Vainio 2010-05-26 20:50:10 UTC
(In reply to comment #14)
It works with this change, thanks!

Comment 16 Fedora Update System 2010-05-27 18:37:07 UTC
gpodder-2.6-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gpodder'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gpodder-2.6-3.fc13

Comment 17 Fedora Update System 2010-05-31 18:22:09 UTC
gpodder-2.6-6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gpodder'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gpodder-2.6-6.fc13

Comment 18 Fedora Update System 2010-06-07 22:27:24 UTC
gpodder-2.6-7.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gpodder'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gpodder-2.6-7.fc13

Comment 19 Fedora Update System 2010-06-14 17:10:01 UTC
gpodder-2.6-7.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.