Bug 596354 - guestfish.1.html and guestfs.3.html declared "XHTML 1.0 Strict" but are not in fact well-formed XML
guestfish.1.html and guestfs.3.html declared "XHTML 1.0 Strict" but are not i...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 12:14 EDT by Richard W.M. Jones
Modified: 2012-11-30 10:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:12:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Validation errors in guestfish.1.html (606 bytes, text/plain)
2010-05-26 12:21 EDT, Richard W.M. Jones
no flags Details
Validation errors in guestfs.3.html (1.79 KB, text/plain)
2010-05-26 12:21 EDT, Richard W.M. Jones
no flags Details

  None (edit)
Description Richard W.M. Jones 2010-05-26 12:14:50 EDT
Description of problem:

Using xmllint to validate these two files gives the
errors which I will attach.

Version-Release number of selected component (if applicable):

libguestfs 1.3.16

How reproducible:

Always.

Steps to Reproduce:
1. xmllint --valid /usr/share/doc/libguestfs-devel-1.3.16/guestfs.3.html > /dev/null
2. xmllint --valid /usr/share/doc/guestfish-1.3.16/guestfish.1.html > /dev/null
3.
  
Actual results:

Validation errors.

Expected results:

Should be strict XHTML.

Additional info:
Comment 1 Richard W.M. Jones 2010-05-26 12:21:26 EDT
Created attachment 416913 [details]
Validation errors in guestfish.1.html
Comment 2 Richard W.M. Jones 2010-05-26 12:21:49 EDT
Created attachment 416915 [details]
Validation errors in guestfs.3.html
Comment 3 Richard W.M. Jones 2012-11-30 10:12:52 EST
Since this commit we are no longer claiming that the HTML
files are Strict.  (In fact, the Perl class doesn't even
bother adding a DOCTYPE at all).

commit 1e17a32060feb937b3972f61b37f9116ad7d8d9a
Author: Richard W.M. Jones <rjones@redhat.com>
Date:   Mon Jul 16 19:41:39 2012 +0100

    Replace podwrapper shell script with custom Perl script.
    
    This uses Pod::Simple so it properly parses the input POD and can
    generate proper custom output as required specifically by libguestfs.
    
    One immediate benefit is that links between and within manual pages
    now work mostly correctly.

Note You need to log in before you can comment on or make changes to this bug.