Bug 596380 - The Live CD of Fedora 13 x64 does not boot in UEFI
The Live CD of Fedora 13 x64 does not boot in UEFI
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 13:08 EDT by Franklin Tse
Modified: 2013-01-10 00:58 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-22 20:20:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Franklin Tse 2010-05-26 13:08:55 EDT
Description of problem:
Although the document mentions the CD includes boot catalog entries for both BIOS and UEFI firmware interfaces, my motherboard's internal boot manager does not find the UEFI boot catalog entry in the CD. However, the installation DVD of Windows 7 Professional x64 is fine.

How reproducible:
Always reproducible

Steps to Reproduce:
1. Burn Fedora-13-x86_64-Live.iso into a CD
2. Try to boot a computer supporting UEFI with that CD
  
Actual results:
The UEFI boot catalog entry in the CD is not found/recognized

Expected results:
Boot into Fedora 13 x64 with that CD via UEFI

Additional info:
Motherboard: Intel Desktop Board DP55WG, BIOS Version 4905
Comment 1 Matt Domsch 2010-05-26 13:44:30 EDT
reassigning to "distribution" as it can't be efibootmgr's problem (that code isn't even run by that point).  Could also be anaconda or livecd-creator I suppose...
Comment 2 Peter Jones 2010-05-26 16:19:56 EDT
I don't think the intent is to have the livecd be EFI bootable - the tools in question seem to be designed to make a usb stick EFI bootable, but there's really no code there to make the CD bootable this way.

(I'm reassigning to livecd-tools for them to weigh in, though.)
Comment 3 Franklin Tse 2010-05-26 20:45:22 EDT
According to Section 7.4 of the Installation Guide,

"The CD and DVD media include boot catalog entries for both BIOS and UEFI firmware interfaces. This allows you to boot systems based on either firmware interface from the same CD or DVD. However, some systems with very old BIOS implementations cannot handle media with more than one boot catalog entry. These systems will not boot from the CD or DVD and you must instead boot them from USB or PXE."

So, if the Live CD isn't UEFI bootable at the moment, maybe the Guide has to updated.
Comment 4 Jesse Keating 2010-05-26 23:48:38 EDT
I believe that is referring to the traditional install CD or DVD, not the Live media.
Comment 5 Peter Jones 2010-05-27 10:14:36 EDT
Also, I think that section is just plain wrong anyway, at least for Fedora - it looks correct for RHEL. In Fedora up through 13 (inclusive), we make boot.iso UEFI bootable but not Fedora-13-x86_64-DVD.iso or Fedora-13-x86_64-disc1.iso . We also provide efidisk.img, which is a disk image suitable for using on a USB key. The reasoning in that text is right, but the details are backwards.

Corrections to the Installation Guide belong in a separate bug, I think.
Comment 6 Franklin Tse 2010-05-27 10:54:16 EDT
I see. How about Fedora-13-x86_64-DVD.iso?
Comment 7 Franklin Tse 2010-05-27 10:58:19 EDT
(In reply to comment #5)

Oops... I didn't read the comment careful enough and mixed up Fedora-13-x86_64-Live.iso and Fedora-13-x86_64-DVD.iso. Please disregard my previous comment. Thanks!
Comment 8 Franklin Tse 2010-05-27 12:38:45 EDT
Created Bug 596856 for the documation bug.
Created Bug 596859 for the system failure when booting with boot.iso

Leaving this bug active for no UEFI support in Live CD and Installation DVD
Comment 9 Fedora Admin XMLRPC Client 2010-10-21 13:57:34 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.