Bug 596387 - DVD-based upgrade from F12 on x86_64 fails
Summary: DVD-based upgrade from F12 on x86_64 fails
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 17:18 UTC by Patrick O'Callaghan
Modified: 2011-03-04 23:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-04 23:12:39 UTC
Type: ---


Attachments (Terms of Use)
Tarball of install logs (22.86 KB, application/x-gzip)
2010-05-26 20:11 UTC, Patrick O'Callaghan
no flags Details
/tmp/syslog (62.74 KB, text/plain)
2010-05-26 21:37 UTC, Patrick O'Callaghan
no flags Details

Description Patrick O'Callaghan 2010-05-26 17:18:00 UTC
Description of problem:
Can't upgrade from F12 to F13 using the Installation DVD for x86_64. 

Version-Release number of selected component (if applicable):


How reproducible:
Repeatable.

Steps to Reproduce:
1.Insert Install DVD
2.Progress until Disk Selection screen and configure
3.Press Next
  
Actual results:
Error message: "Unable to read package metadata. This may be due to a missing
repodata directory. Please ensure that your install tree has
been correctly generated.
         
Cannot retrieve repository metadata (repomd.xml) for repository:
anaconda-InstallationRepo-201005130101.x86_64. Please verify its
path and try again."

Expected results:
Successful upgrade.

Additional info:
The DVD was downloaded using Bittorrent via the tracker posted on the Fedora BT page. It passed the sha256sum check and the install media check (twice). The DVD boots and everything seems fine until the above error message.

Comment 1 Patrick O'Callaghan 2010-05-26 18:23:29 UTC
Minor correction: the error message appears on clicking Next at the Grub configuration screen (which was left at its default setting).

Comment 2 Chris Lumens 2010-05-26 19:01:59 UTC
Please attach /tmp/*.log from when you hit this error to this bug report.

Comment 3 Patrick O'Callaghan 2010-05-26 20:11:11 UTC
Created attachment 417016 [details]
Tarball of install logs

Complete logs from install attempt.

Comment 4 Chris Lumens 2010-05-26 20:49:30 UTC
Is there also a /tmp/syslog?  I guess my glob wasn't really as useful as I had hoped.  If I was to take a stab at this, I'd guess that there's an error reading your DVD media so anaconda tried to fall back on the network source, which doesn't work due to the network not being available.  That's all conjecture for now, though.

Comment 5 Patrick O'Callaghan 2010-05-26 21:18:04 UTC
I'll see if there's a /tmp/syslog and post it if so. However I checked the media twice with mediacheck and also made sure it was readable by ripping the DVD to an image file and doing a bytewise compare with the original image. The result is an EOF on the original image, which I interpret as an artifact of the DVD structure. The two files are respectively 3630045184 (original) and 3630071808 (ripped) bytes long.

Perhaps if I knew what specific file Anaconda is looking for I could do a manual check. There is a repomd.xml file but nothing in the contents looks even approximately like "anaconda-InstallationRepo-201005130101.x86_64".

Comment 6 Patrick O'Callaghan 2010-05-26 21:37:32 UTC
Created attachment 417038 [details]
/tmp/syslog

/tmp/syslog from failed install session.

Comment 7 Patrick O'Callaghan 2010-05-27 06:01:05 UTC
Further info: I copied the install image to a pendrive and booted from there (had to disable EDD for some reason but that was the only change). I get exactly the same error.

This would seem to eliminate the DVD media and the optical drive as sources of the problem. It's definitely a bug in the image itself. I am as certain as I can be that the image is correct as it passes every possible checksum test (I even double-checked with the online copy of the checksum to make sure I hadn't got a spoofed version of the image).

Comment 8 Patrick O'Callaghan 2010-05-27 22:18:16 UTC
I decided to try installing via a boot.iso disk, so I created a bootable pendrive containing boot.iso and fired it up using the "askmethod" incantation (BTW the docmentation on how to do this is deficient; I'll file a separate bug report on that). I then told it to use the DVD as its repo.

At first I got exactly the same error as before, but this time I clicked on the Edit button to see if there was anything worth changing. I looked at the drop-down menu (it offered NFS/FTP, CD/DVD and Hard Disk if I remember correctly). CD/DVD was selected of course, and I didn't change it. Nor did I change the repo name field ("Installation Repository"). On closing the Edit dialogue I then hit Retry.

The system started installing.

To repeat: I changed nothing at all (I know, they all say that, but it's literally true), but now it worked. On previous occasions I had hit Retry and even the Edit dialogue to no effect, but now the system installed.

Maybe it needed time for some bus to settle, or it was the time of day, the day of the month, the phase of the moon, whatever. Or maybe there's a Heisenbug in Anaconda. Right now, I'll believe anything but F13 is now installed on my system.


Note You need to log in before you can comment on or make changes to this bug.